summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild')
-rw-r--r--x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild b/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild
new file mode 100644
index 000000000000..53e2e68dbd8f
--- /dev/null
+++ b/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE="http://www.cypherpunks.ca/otr/"
+SRC_URI="http://www.cypherpunks.ca/otr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/libgcrypt:0
+ net-im/pidgin[gtk]
+ >=net-libs/libotr-4.0.0
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}"
+# autoconf-archive for F_S patch
+BDEPEND="
+ dev-util/intltool
+ dev-build/autoconf-archive
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.2-dont-clobber-fortify-source.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}