summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-otr')
-rw-r--r--x11-plugins/pidgin-otr/files/pidgin-otr-4.0.2-dont-clobber-fortify-source.patch21
-rw-r--r--x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r2.ebuild (renamed from x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r1.ebuild)7
-rw-r--r--x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild45
3 files changed, 73 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-otr/files/pidgin-otr-4.0.2-dont-clobber-fortify-source.patch b/x11-plugins/pidgin-otr/files/pidgin-otr-4.0.2-dont-clobber-fortify-source.patch
new file mode 100644
index 000000000000..e630185cc45f
--- /dev/null
+++ b/x11-plugins/pidgin-otr/files/pidgin-otr-4.0.2-dont-clobber-fortify-source.patch
@@ -0,0 +1,21 @@
+Don't clobber our toolchain defaults.
+
+https://bugs.gentoo.org/898526
+--- a/configure.ac
++++ b/configure.ac
+@@ -141,7 +141,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
+ ])], have_clang=yes, have_clang=no)
+
+ if test x$enable_gcc_hardening != xno; then
+- CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=2"
++ CFLAGS="$CFLAGS"
+ if test x$have_clang = xyes; then
+ OTR_CHECK_CFLAGS(-Qunused-arguments)
+ fi
+@@ -166,4 +166,6 @@ if test x$enable_linker_hardening != xno; then
+ OTR_CHECK_LDFLAGS(-z relro -z now, "$all_ldflags_for_check", "$all_libs_for_check")
+ fi
+
++AX_ADD_FORTIFY_SOURCE
++
+ AC_OUTPUT([Makefile po/Makefile.in])
diff --git a/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r1.ebuild b/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r2.ebuild
index fce6c905d795..e6f68bb0cbb3 100644
--- a/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r1.ebuild
+++ b/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r2.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
HOMEPAGE="http://www.cypherpunks.ca/otr/"
SRC_URI="http://www.cypherpunks.ca/otr/${P}.tar.gz"
@@ -24,6 +26,11 @@ BDEPEND="
DOCS=( AUTHORS ChangeLog NEWS README )
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_install() {
default
diff --git a/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild b/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild
new file mode 100644
index 000000000000..53e2e68dbd8f
--- /dev/null
+++ b/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE="http://www.cypherpunks.ca/otr/"
+SRC_URI="http://www.cypherpunks.ca/otr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/libgcrypt:0
+ net-im/pidgin[gtk]
+ >=net-libs/libotr-4.0.0
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}"
+# autoconf-archive for F_S patch
+BDEPEND="
+ dev-util/intltool
+ dev-build/autoconf-archive
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.2-dont-clobber-fortify-source.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}