summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-sipe')
-rw-r--r--x11-plugins/pidgin-sipe/files/pidgin-sipe-1.25.0-bashisms.patch53
-rw-r--r--x11-plugins/pidgin-sipe/metadata.xml4
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild13
3 files changed, 66 insertions, 4 deletions
diff --git a/x11-plugins/pidgin-sipe/files/pidgin-sipe-1.25.0-bashisms.patch b/x11-plugins/pidgin-sipe/files/pidgin-sipe-1.25.0-bashisms.patch
new file mode 100644
index 000000000000..083d41bd0fde
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/files/pidgin-sipe-1.25.0-bashisms.patch
@@ -0,0 +1,53 @@
+Fix bashisms in configure script.
+
+Bug: https://bugs.gentoo.org/821451
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -444,10 +444,10 @@
+ [PKG_CHECK_MODULES(_SIPE_MEDIA_RECHECK_PLEASE_IGNORE, [$purple_pkgconfig >= 2.8.0],
+ dnl check purple pkgconfig for gstreamer version
+ [gstreamer_pkgconfig=`$PKG_CONFIG --variable=gstreamer $purple_pkgconfig`
+- AS_IF([test "x$gstreamer_pkgconfig" == x],
+- [AS_IF([test "x$purple_pkgconfig" == xpurple-3],
++ AS_IF([test "x$gstreamer_pkgconfig" = x],
++ [AS_IF([test "x$purple_pkgconfig" = xpurple-3],
+ [gstreamer_pkgconfig=1.0])])
+- AS_IF([test "x$gstreamer_pkgconfig" == x1.0],
++ AS_IF([test "x$gstreamer_pkgconfig" = x1.0],
+ [gstreamer_pkgconfig="gstreamer-$gstreamer_pkgconfig gstreamer-rtp-$gstreamer_pkgconfig"
+
+ AC_MSG_NOTICE([using packages "$gstreamer_pkgconfig".])
+@@ -556,18 +556,18 @@
+ AM_CONDITIONAL(SIPE_WITH_VV, [test "x$with_purple_vv" != xno])
+
+ dnl raw data RTP streams enable Lync file transfer
+-AM_CONDITIONAL(SIPE_HAVE_XDATA, [test "x$ac_have_xdata" == xyes])
+-AS_IF([test "x$ac_have_xdata" == xyes],
++AM_CONDITIONAL(SIPE_HAVE_XDATA, [test "x$ac_have_xdata" = xyes])
++AS_IF([test "x$ac_have_xdata" = xyes],
+ [AC_DEFINE(HAVE_XDATA, 1, [Define if we have raw data RTP in media backend.])])
+
+ dnl enable appshare support
+-AM_CONDITIONAL(SIPE_HAVE_APPSHARE, [test "x$ac_have_appshare" == xyes])
+-AS_IF([test "x$ac_have_appshare" == xyes],
++AM_CONDITIONAL(SIPE_HAVE_APPSHARE, [test "x$ac_have_appshare" = xyes])
++AS_IF([test "x$ac_have_appshare" = xyes],
+ [AC_DEFINE(HAVE_APPSHARE, 1, [Define to 1 if we have appshare support.])])
+
+ dnl RDP server for sharing local desktop
+ AM_CONDITIONAL(SIPE_HAVE_APPSHARE_SERVER, [test "x$ac_have_appshare_server" = xyes])
+-AS_IF([test "x$ac_have_appshare_server" == xyes],
++AS_IF([test "x$ac_have_appshare_server" = xyes],
+ [AC_DEFINE(HAVE_APPSHARE_SERVER, 1, [Define if appshare server is enabled.])])
+
+ dnl libpurple API relies on GParameter (deprecated in glib-2.0 >= 2.62.0)
+@@ -584,7 +584,7 @@
+ [We need GValueArray for which no replacement is available])
+ ])
+ dnl libpurple 2.x API relies on G_CONST_RETURN (deprecated in glib-2.0 >= 2.30.0)
+-AS_IF([test "x$purple_pkgconfig" == xpurple],
++AS_IF([test "x$purple_pkgconfig" = xpurple],
+ [AC_DEFINE(GLIB_VERSION_MIN_REQUIRED, GLIB_VERSION_2_28,
+ [libpurple 2.x API uses G_CONST_RETURN])
+ ])
diff --git a/x11-plugins/pidgin-sipe/metadata.xml b/x11-plugins/pidgin-sipe/metadata.xml
index ce435e0f5671..e7d8bfdc253b 100644
--- a/x11-plugins/pidgin-sipe/metadata.xml
+++ b/x11-plugins/pidgin-sipe/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<!-- maintainer-needed -->
<longdescription lang="en">
-An Open Implementation of SIP/Simple protocol for Live Communications Server 2003/2005/2007 and Lync.
-</longdescription>
+ An Open Implementation of SIP/Simple protocol for Live Communications Server 2003/2005/2007 and Lync.
+ </longdescription>
<use>
<flag name="ocs2005-message-hack">Disable message timeout for OCS2005 clients which causes "false" not delivered error messages</flag>
<flag name="telepathy">Support use as a telepathy backend</flag>
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
index 4b73a6e3e9c1..b1c06e93f654 100644
--- a/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
HOMEPAGE="http://sipe.sourceforge.net/"
-SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/sipe/${P}.tar.gz"
+
+inherit autotools
LICENSE="GPL-2"
SLOT="0"
@@ -43,6 +45,13 @@ BDEPEND="
virtual/pkgconfig
"
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.25.0-bashisms.patch
+
+ eautoreconf
+ default
+}
+
src_configure() {
local myeconfargs=(
--enable-purple