summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-window_merge/pidgin-window_merge-0.3-r1.ebuild')
-rw-r--r--x11-plugins/pidgin-window_merge/pidgin-window_merge-0.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-window_merge/pidgin-window_merge-0.3-r1.ebuild b/x11-plugins/pidgin-window_merge/pidgin-window_merge-0.3-r1.ebuild
new file mode 100644
index 000000000000..5fbc54811550
--- /dev/null
+++ b/x11-plugins/pidgin-window_merge/pidgin-window_merge-0.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A Pidgin plugin that merges the Buddy List window with a conversation window"
+HOMEPAGE="https://github.com/dm0-/window_merge"
+SRC_URI="https://github.com/downloads/dm0-/${PN#pidgin-}/${P#pidgin-}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2=
+ net-im/pidgin:0=[gtk]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P#pidgin-}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ ewarn "This plugin and infopane plugin (purple-plugin_pack) activated"
+ ewarn "at the same time cause a segfault in pidgin"
+ ewarn "see https://github.com/dm0-/window_merge/issues/4"
+}