summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild')
-rw-r--r--x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild b/x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild
new file mode 100644
index 000000000000..2efdcf51b98c
--- /dev/null
+++ b/x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+PYTHON_DEPEND=2
+
+inherit base python
+
+DESCRIPTION="A PyGTK based HDAPS monitor"
+HOMEPAGE="http://thpani.at/projects/thinkhdaps/"
+SRC_URI="http://thpani.at/media/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/libgnome-python:2
+ dev-python/pygobject:2
+ dev-python/pygtk:2"
+
+DOCS=( AUTHORS NEWS )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ econf --enable-desktop PYTHON=$(PYTHON -2 --absolute-path)
+}