summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild')
-rw-r--r--x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild b/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild
index 9619fe673e8c..cc153566aa1a 100644
--- a/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild
+++ b/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,10 +22,17 @@ DEPEND="${RDEPEND}
DOCS=( ../Changelog )
-S="${WORKDIR}/${P}/${PN}"
+S=${WORKDIR}/${P}/${PN}
PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+src_prepare() {
+ default
+
+ pushd "${WORKDIR}"/${P} || die
+ eapply "${FILESDIR}"/${P}-fno-common.patch
+}
+
src_compile() {
emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
}