summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild')
-rw-r--r--x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
index d902e3de4a33..ffc03d2648bb 100644
--- a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
+++ b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=6
DESCRIPTION="DockApp monitors the temperature and Speedstep features in ACPI-based systems"
HOMEPAGE="http://www.vrlteam.org/wmacpimon/"
@@ -19,18 +18,18 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-src_prepare() {
+PATCHES=(
# patch wmacpimon.c file to set default path for
# wmacpimon.prc to /var/tmp/
- epatch "${FILESDIR}"/wmacpimon.c.patch
+ "${FILESDIR}/wmacpimon.c.patch"
# fix LDFLAGS ordering. See bug #248618.
# fix LDFLAGS ordering again and other stuff. See bug #336091.
- epatch "${FILESDIR}"/Makefile.patch
-}
+ "${FILESDIR}/Makefile.patch"
+)
src_install() {
- dobin wmacpimond wmacpimon || die "dobin failed."
+ dobin wmacpimond wmacpimon
dodoc AUTHORS ChangeLog README
newinitd "${FILESDIR}"/wmacpimon.initscript wmacpimon
}