summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmbiff/wmbiff-0.4.33.ebuild')
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.33.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.33.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.33.ebuild
new file mode 100644
index 000000000000..4c3609d57973
--- /dev/null
+++ b/x11-plugins/wmbiff/wmbiff-0.4.33.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools eutils
+
+DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes"
+HOMEPAGE="https://www.dockapps.net/wmbiff"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.1:0
+ >=net-libs/gnutls-2.2.0
+ )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+DOCS="ChangeLog FAQ NEWS README TODO wmbiff/sample.wmbiffrc"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${PN}-0.4.27-invalid-strncpy.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable crypt crypto)
+}