summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmbinclock')
-rw-r--r--x11-plugins/wmbinclock/Manifest1
-rw-r--r--x11-plugins/wmbinclock/metadata.xml10
-rw-r--r--x11-plugins/wmbinclock/wmbinclock-0.51.ebuild34
3 files changed, 40 insertions, 5 deletions
diff --git a/x11-plugins/wmbinclock/Manifest b/x11-plugins/wmbinclock/Manifest
index 8af14cabb4c6..efc0adc2e99b 100644
--- a/x11-plugins/wmbinclock/Manifest
+++ b/x11-plugins/wmbinclock/Manifest
@@ -1 +1,2 @@
DIST wmbinclock-0.5.tar.bz2 15909 BLAKE2B 71a5e53fea8f042bd8e01c0a8dde9057b22e398a4d483b556221d8344b5542f097e835f0d4eafd7cf24964b4b08f04f844c476cddc443ebc8f469e8fbb5142ec SHA512 f0f1f46b19e9c34f9168e03df2d4be2f9c7a73b09dd8247a7bc977309a3354069adf34032f3c0106aa763fe259993176edd84b029941191d05a11505e27de695
+DIST wmbinclock-0.51.tar.gz 11501 BLAKE2B f727a9497a452525bf08daf1a30e8485ca85777a0b938c45634a779cd1adb92afd172ec9455b46e832761d8a45df7a57a4bd93ebbeaa4637da5edb6087f7e30c SHA512 343ac121c93801d69beeef6b4e5ca52020229f61ac723de9b7ee7bea3fb50c51d793b217f848ba9672eb97ec1b70629186e29c27f907798af9d33d5a4faea069
diff --git a/x11-plugins/wmbinclock/metadata.xml b/x11-plugins/wmbinclock/metadata.xml
index 7c94bb940cde..e92ba7ab9911 100644
--- a/x11-plugins/wmbinclock/metadata.xml
+++ b/x11-plugins/wmbinclock/metadata.xml
@@ -6,11 +6,11 @@
<name>Bernard Cafarelli</name>
</maintainer>
<longdescription>
-The windowmaker Binary Clock applet shows the
-actual system time as a binary clock. You have to
-add up the bits to get the time. The clock has a
-24-hour format.
-</longdescription>
+ The windowmaker Binary Clock applet shows the
+ actual system time as a binary clock. You have to
+ add up the bits to get the time. The clock has a
+ 24-hour format.
+ </longdescription>
<upstream>
<remote-id type="sourceforge">wmbinclock</remote-id>
</upstream>
diff --git a/x11-plugins/wmbinclock/wmbinclock-0.51.ebuild b/x11-plugins/wmbinclock/wmbinclock-0.51.ebuild
new file mode 100644
index 000000000000..96741ece7841
--- /dev/null
+++ b/x11-plugins/wmbinclock/wmbinclock-0.51.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="a nifty little binary clock dockapp"
+HOMEPAGE="https://www.dockapps.net/wmbinclock"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.5-gcc-10.patch )
+DOCS=( CHANGELOG README.md )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
+ INCDIR="-I/usr/include/X11" LIBDIR="" \
+ SYSTEM="${LDFLAGS}"
+}
+
+src_install() {
+ dobin wmBinClock
+ einstalldocs
+}