summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmfortune')
-rw-r--r--x11-plugins/wmfortune/files/wmfortune-0.241-stringh.patch6
-rw-r--r--x11-plugins/wmfortune/wmfortune-0.241-r1.ebuild40
2 files changed, 43 insertions, 3 deletions
diff --git a/x11-plugins/wmfortune/files/wmfortune-0.241-stringh.patch b/x11-plugins/wmfortune/files/wmfortune-0.241-stringh.patch
index a8e9f9ff6eda..35db475df300 100644
--- a/x11-plugins/wmfortune/files/wmfortune-0.241-stringh.patch
+++ b/x11-plugins/wmfortune/files/wmfortune-0.241-stringh.patch
@@ -1,6 +1,6 @@
-diff -ur wmfortune-0.241.orig/wmfortune.c wmfortune-0.241/wmfortune.c
---- wmfortune-0.241.orig/wmfortune.c 2001-09-01 03:25:39.000000000 +0300
-+++ wmfortune-0.241/wmfortune.c 2008-01-15 10:21:17.000000000 +0200
+diff -ur a/wmfortune.c b/wmfortune.c
+--- a/wmfortune.c 2001-09-01 03:25:39.000000000 +0300
++++ b/wmfortune.c 2008-01-15 10:21:17.000000000 +0200
@@ -25,6 +25,7 @@
#include <unistd.h>
diff --git a/x11-plugins/wmfortune/wmfortune-0.241-r1.ebuild b/x11-plugins/wmfortune/wmfortune-0.241-r1.ebuild
new file mode 100644
index 000000000000..f67de2f9282a
--- /dev/null
+++ b/x11-plugins/wmfortune/wmfortune-0.241-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp showing fortune-mod messages"
+HOMEPAGE="https://www.dockapps.net/wmfortune"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="games-misc/fortune-mod
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=( "${FILESDIR}"/${P}-stringh.patch )
+
+src_prepare() {
+ # Honour Gentoo LDFLAGS. Closes bug #336446.
+ sed -i 's/-o $(DEST)/$(LDFLAGS) -o $(DEST)/' Makefile || die
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}" \
+ XLIBDIR="/usr/$(get_libdir)"
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}