summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmget/wmget-0.6.1-r1.ebuild')
-rw-r--r--x11-plugins/wmget/wmget-0.6.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-plugins/wmget/wmget-0.6.1-r1.ebuild b/x11-plugins/wmget/wmget-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..07279d269605
--- /dev/null
+++ b/x11-plugins/wmget/wmget-0.6.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Libcurl based dockapp for automated downloads"
+HOMEPAGE="https://www.dockapps.net/wmget"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+# Specific to this tarball
+S="${WORKDIR}/dockapps-5aaf842"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ >=net-misc/curl-7.9.7"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ default
+ eautoreconf
+}