summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild')
-rw-r--r--x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild b/x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild
new file mode 100644
index 000000000000..8974ea955454
--- /dev/null
+++ b/x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="CPU and SYS temperature dockapp"
+HOMEPAGE="http://www.fluxcode.net"
+SRC_URI="http://www.fluxcode.net/${P}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ =sys-apps/lm_sensors-3*
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-list.patch
+
+ sed -i -e "s:-Wall -g:\$(CFLAGS):" src/Makefile || die "sed failed."
+
+ #Honour Gentoo LDFLAGS, rationalizing Makefile - see bug #337411.
+ sed -i -e "s:LDFLAGS =:LIBS =:" src/Makefile || die "sed failed."
+ sed -i -e "s:\$(LDFLAGS) -o \$(BINARY):\$(LDFLAGS) -o \$(BINARY) \$(LIBS):" src/Makefile || die "sed failed."
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dodoc BUGS CREDITS README TODO
+ dobin src/wmgtemp
+ doman wmgtemp.1
+}