summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmhdplop/files')
-rw-r--r--x11-plugins/wmhdplop/files/wmhdplop-0.9.10-cflags.patch14
-rw-r--r--x11-plugins/wmhdplop/files/wmhdplop-0.9.10-sysmacros.patch11
-rw-r--r--x11-plugins/wmhdplop/files/wmhdplop-0.9.11-configure.patch108
-rw-r--r--x11-plugins/wmhdplop/files/wmhdplop-0.9.11-indent.patch38
-rw-r--r--x11-plugins/wmhdplop/files/wmhdplop-0.9.12-configure.patch14
-rw-r--r--x11-plugins/wmhdplop/files/wmhdplop-0.9.9-64bit.patch94
6 files changed, 160 insertions, 119 deletions
diff --git a/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-cflags.patch b/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-cflags.patch
deleted file mode 100644
index 999379988317..000000000000
--- a/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-cflags.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Naur wmhdplop-0.9.10.orig/configure.ac wmhdplop-0.9.10/configure.ac
---- wmhdplop-0.9.10.orig/configure.ac 2016-11-24 16:18:21.000000000 +0100
-+++ wmhdplop-0.9.10/configure.ac 2016-12-02 11:58:28.276017676 +0100
-@@ -19,10 +19,6 @@
- AC_DEFINE(_GNU_SOURCE,[],[uses GNU extensions])
-
-
--if test x$GCC = xyes; then
-- CFLAGS="-O3 -fomit-frame-pointer -ffast-math -Wall -W";
--fi
--
- dnl check for X
- AC_PATH_X
- AC_PATH_XTRA
diff --git a/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-sysmacros.patch b/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-sysmacros.patch
deleted file mode 100644
index 1346cd2e3641..000000000000
--- a/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-sysmacros.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur wmhdplop-0.9.10.orig/devnames.c wmhdplop-0.9.10/devnames.c
---- wmhdplop-0.9.10.orig/devnames.c 2016-11-24 15:49:55.000000000 +0100
-+++ wmhdplop-0.9.10/devnames.c 2017-02-16 15:03:08.946447885 +0100
-@@ -4,6 +4,7 @@
- #include <string.h>
- #include <sys/types.h>
- #include <sys/stat.h>
-+#include <sys/sysmacros.h>
- #include <unistd.h>
- #include <linux/major.h>
- #include <ctype.h>
diff --git a/x11-plugins/wmhdplop/files/wmhdplop-0.9.11-configure.patch b/x11-plugins/wmhdplop/files/wmhdplop-0.9.11-configure.patch
new file mode 100644
index 000000000000..1bbe3ad2f388
--- /dev/null
+++ b/x11-plugins/wmhdplop/files/wmhdplop-0.9.11-configure.patch
@@ -0,0 +1,108 @@
+diff -Naur wmhdplop-0.9.11.orig/configure.ac wmhdplop-0.9.11/configure.ac
+--- wmhdplop-0.9.11.orig/configure.ac 2018-12-11 02:45:33.000000000 +0100
++++ wmhdplop-0.9.11/configure.ac 2022-07-15 19:42:42.504309025 +0200
+@@ -1,12 +1,14 @@
+-AC_INIT(wmhdplop, 0.9.11)
++AC_INIT([wmhdplop], [0.9.11], [https://www.dockapps.net/wmhdplop])
+ AC_CONFIG_SRCDIR(wmhdplop.c)
+ AM_INIT_AUTOMAKE
++LT_INIT
++AC_CONFIG_MACRO_DIRS([m4])
+ AM_CONFIG_HEADER(config.h)
+
+ AC_SUBST(VERSION)
+
+ ISODATE=`date +%Y-%m-%d`
+-AC_SUBST(ISODATE)
++AC_SUBST([ISODATE])
+
+ AC_CANONICAL_HOST
+
+@@ -19,39 +21,37 @@
+ AC_DEFINE(_GNU_SOURCE,[],[uses GNU extensions])
+
+
+-if test x$GCC = xyes; then
+- CFLAGS="-O3 -fomit-frame-pointer -ffast-math -Wall -W";
+-fi
+-
+ dnl check for X
+ AC_PATH_X
+ AC_PATH_XTRA
+-if test x$no_x = xyes; then
+- echo "You need to supply the path to the X headers and libraries with --x-includes=dir and --x-libraries=dir";
+- exit 1;
+-fi;
++AS_IF(
++ [test "x${no_x}" = "xyes"],
++ [AC_MSG_ERROR([You need to supply the path to the X headers and libraries with --x-includes=dir and --x-libraries=dir])]
++)
+
+ LIBS="${X_PRE_LIBS} ${X_LIBS} -lX11 -lXext ${LIBS} ${X_EXTRA_LIBS}"
+ CFLAGS="$CFLAGS $X_CFLAGS"
+
+ dnl Checks for library functions.
+-AC_CHECK_HEADERS(linux/hdreg.h)
++AC_CHECK_HEADERS([linux/hdreg.h])
+
+-AC_CHECK_PROG([IMLIB2_CONFIG_IN_PATH],[imlib2-config],[yes],[no])
+-if test "x$IMLIB2_CONFIG_IN_PATH" = "xno"; then
+- AC_ERROR([imlib2-config not found in PATH.. You need to install Imlib2 (and its developpement package)])
+-fi
+-IMLIB2_CFLAGS=$(imlib2-config --cflags)
+-IMLIB2_LIBS=$(imlib2-config --libs)
+-AC_SUBST(IMLIB2_CFLAGS)
+-AC_SUBST(IMLIB2_LIBS)
++AC_CHECK_PROG([PKG_CONFIG_IN_PATH],[pkg-config],[yes],[no])
++AS_IF(
++ [test "x$PKG_CONFIG_IN_PATH" = "xno"],
++ [AC_ERROR([pkg-config not found in PATH.. You need to install pkgconf])]
++)
++
++IMLIB2_CFLAGS=$(pkg-config imlib2 --cflags)
++IMLIB2_LIBS=$(pkg-config imlib2 --libs)
++AC_SUBST([IMLIB2_CFLAGS])
++AC_SUBST([IMLIB2_LIBS])
+
+ YELLOW="\\033\\1331;33m"
+ RESET="\\033\\1330m"
+
+ dnl Checks for the gkrellm plugin
+ build_gkhdplop="yes"
+-AC_ARG_ENABLE(gkrellm,
++AC_ARG_ENABLE([gkrellm],
+ [ --enable-gkrellm build the gkrellm plugin (requires gtk2 and gkrellm developpement files) (Default is yes)
+ --disable-gkrellm do not build the gkrellm plugin],
+ [ if test "x$enableval" = "xno" ; then
+@@ -69,8 +69,8 @@
+ PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
+ GTK2_CFLAGS=$PACKAGE_CFLAGS;
+ GTK2_LIBS=$PACKAGE_LIBS;
+- AC_SUBST(GTK2_CFLAGS)
+- AC_SUBST(GTK2_LIBS)
++ AC_SUBST([GTK2_CFLAGS])
++ AC_SUBST([GTK2_LIBS])
+ SAVECPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CFLAGS $GTK2_CFLAGS"
+ AC_CHECK_HEADERS([gkrellm2/gkrellm.h], [ok=1], [ok=0])
+@@ -82,7 +82,7 @@
+ fi
+ CPPFLAGS="$SAVECPPFLAGS"
+ fi
+-AC_SUBST(GKHDPLOP)
++AC_SUBST([GKHDPLOP])
+
+
+ AC_OUTPUT(Makefile)
+diff -Naur wmhdplop-0.9.11.orig/Makefile.am wmhdplop-0.9.11/Makefile.am
+--- wmhdplop-0.9.11.orig/Makefile.am 2018-12-08 22:48:27.000000000 +0100
++++ wmhdplop-0.9.11/Makefile.am 2022-07-15 19:42:17.107279593 +0200
+@@ -8,6 +8,8 @@
+
+ EXTRA_DIST=autogen.sh gkrellm_hdplop.c
+
++ACLOCAL_AMFLAGS = -I m4
++
+ IMLIB2_LIBS=@IMLIB2_LIBS@
+ IMLIB2_CFLAGS=@IMLIB2_CFLAGS@
+
diff --git a/x11-plugins/wmhdplop/files/wmhdplop-0.9.11-indent.patch b/x11-plugins/wmhdplop/files/wmhdplop-0.9.11-indent.patch
new file mode 100644
index 000000000000..30e44715ea2a
--- /dev/null
+++ b/x11-plugins/wmhdplop/files/wmhdplop-0.9.11-indent.patch
@@ -0,0 +1,38 @@
+From f597fc7288f57d1dfddd5bb559cc7b0f598d15e5 Mon Sep 17 00:00:00 2001
+From: "Torrance, Douglas" <dtorrance@piedmont.edu>
+Date: Sun, 10 Oct 2021 10:01:04 +0000
+Subject: [PATCH] wmhdplop: Fix "misleadingly indented" compiler warnings.
+
+---
+ wmhdplop/wmhdplop.c | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/wmhdplop.c b/wmhdplop.c
+index 16b9a4f..bbbe971 100644
+--- a/wmhdplop.c
++++ b/wmhdplop.c
+@@ -421,7 +421,9 @@ static void draw_hdlist(App *app) {
+ //printf("update : first displayed(%d) = %p\n", cnt, dl);
+
+ for (dl = first_dev_in_list(), dev_cnt=hd_cnt=-1; dl; dl = dl->next) {
+- if (dl->part_id == 0) ++hd_cnt; if (!is_displayed(dl->hd_id, dl->part_id)) continue; ++dev_cnt;
++ if (dl->part_id == 0) ++hd_cnt;
++ if (!is_displayed(dl->hd_id, dl->part_id)) continue;
++ ++dev_cnt;
+ imlib_get_text_size(shorten_name(dl),&w,&h);
+ lw = MAX(w,lw);
+ lh += h;
+@@ -440,7 +442,9 @@ static void draw_hdlist(App *app) {
+ imlib_image_draw_rectangle(lx-1,ly-1,lw+2,lh+2);
+
+ for (dl = first_dev_in_list(), dev_cnt=hd_cnt=-1; dl; dl = dl->next) {
+- if (dl->part_id==0) ++hd_cnt; if (!is_displayed(dl->hd_id, dl->part_id)) continue; ++dev_cnt;
++ if (dl->part_id==0) ++hd_cnt;
++ if (!is_displayed(dl->hd_id, dl->part_id)) continue;
++ ++dev_cnt;
+ int x = lx, y = ly + lh - dev_cnt * h;
+ if (!Prefs.disable_hd_leds) {
+ if (dl->touched_r) {
+--
+2.11.4.GIT
+
diff --git a/x11-plugins/wmhdplop/files/wmhdplop-0.9.12-configure.patch b/x11-plugins/wmhdplop/files/wmhdplop-0.9.12-configure.patch
new file mode 100644
index 000000000000..89718de34818
--- /dev/null
+++ b/x11-plugins/wmhdplop/files/wmhdplop-0.9.12-configure.patch
@@ -0,0 +1,14 @@
+diff -Naur wmhdplop-0.9.12.orig/configure.ac wmhdplop-0.9.12/configure.ac
+--- wmhdplop-0.9.12.orig/configure.ac 2022-08-26 11:38:06.000000000 +0200
++++ wmhdplop-0.9.12/configure.ac 2022-09-14 13:47:56.531041828 +0200
+@@ -18,10 +18,6 @@
+ AC_DEFINE(_GNU_SOURCE,[],[uses GNU extensions])
+
+
+-if test x$GCC = xyes; then
+- CFLAGS="-O3 -fomit-frame-pointer -ffast-math -Wall -W";
+-fi
+-
+ dnl check for X
+ AC_PATH_X
+ AC_PATH_XTRA
diff --git a/x11-plugins/wmhdplop/files/wmhdplop-0.9.9-64bit.patch b/x11-plugins/wmhdplop/files/wmhdplop-0.9.9-64bit.patch
deleted file mode 100644
index 13650e9bb7d9..000000000000
--- a/x11-plugins/wmhdplop/files/wmhdplop-0.9.9-64bit.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-diff -pudr wmhdplop-0.9.9/devnames.h wmhdplop-0.9.9-fixed/devnames.h
---- wmhdplop-0.9.9/devnames.h 2004-04-07 01:14:01.000000000 +0200
-+++ wmhdplop-0.9.9-fixed/devnames.h 2010-06-25 21:56:10.662190796 +0200
-@@ -9,7 +9,7 @@ typedef struct DiskList {
- unsigned major, minor;
- int hd_id, part_id; /* part_id = 0 for disks */
- int enable_hddtemp;
-- int nr, nw, touched_r, touched_w;
-+ long nr, nw, touched_r, touched_w;
- struct DiskList *next;
- } DiskList;
-
-diff -pudr wmhdplop-0.9.9/procstat.c wmhdplop-0.9.9-fixed/procstat.c
---- wmhdplop-0.9.9/procstat.c 2007-04-20 11:12:16.000000000 +0200
-+++ wmhdplop-0.9.9-fixed/procstat.c 2010-06-25 21:55:37.086191145 +0200
-@@ -8,7 +8,7 @@
- static ProcStats ps;
- int use_proc_diskstats;
-
--void pstat_init(struct pstat *pst, int nslice, float update_interval) {
-+void pstat_init(struct pstat *pst, long nslice, float update_interval) {
- pst->nslice = nslice;
- ALLOC_VEC(pst->slices, nslice);
- pst->cur_slice = 0;
-@@ -17,7 +17,7 @@ void pstat_init(struct pstat *pst, int n
- }
-
- float pstat_current(struct pstat *pst) {
-- int idx = pst->cur_slice ? pst->cur_slice-1 : pst->nslice-1;
-+ long idx = pst->cur_slice ? pst->cur_slice-1 : pst->nslice-1;
- return pst->slices[idx]/pst->update_interval;
- }
-
-@@ -101,13 +101,13 @@ void update_stats() {
- if (!Prefs.debug_disk_rd) {
- pstat_add(&ps.disk_read, nr);
- } else {
-- static int cntr = 0; cntr+=(rand()%30) == 0 ? Prefs.debug_disk_rd : 0;
-+ static long cntr = 0; cntr+=(rand()%30) == 0 ? Prefs.debug_disk_rd : 0;
- pstat_add(&ps.disk_read, nr + cntr);
- }
- if (!Prefs.debug_disk_wr) {
- pstat_add(&ps.disk_write, nw);
- } else {
-- static int cntw = 0; cntw+=(rand()%30) == 0 ? Prefs.debug_disk_wr : 0;
-+ static long cntw = 0; cntw+=(rand()%30) == 0 ? Prefs.debug_disk_wr : 0;
- pstat_add(&ps.disk_write, nw + cntw);
- }
- readok = 2;
-@@ -121,7 +121,7 @@ void update_stats() {
- pstat_add(&ps.swap_in, nr);
- pstat_add(&ps.swap_out, nw);
- } else {
-- static int cnt = 0; cnt+=Prefs.debug_swapio;
-+ static long cnt = 0; cnt+=Prefs.debug_swapio;
- pstat_add(&ps.swap_in, nr + cnt);
- pstat_add(&ps.swap_out, nw + cnt);
- }
-@@ -144,10 +144,10 @@ void init_stats(float update_interval) {
- char s[512];
- FILE *f;
-
-- pstat_init(&ps.swap_in, (int)(0.5/update_interval)+1, update_interval);
-- pstat_init(&ps.swap_out, (int)(0.5/update_interval)+1, update_interval);
-- pstat_init(&ps.disk_read, (int)(0.5/update_interval)+1, update_interval);
-- pstat_init(&ps.disk_write, (int)(0.5/update_interval)+1, update_interval);
-+ pstat_init(&ps.swap_in, (long)(0.5/update_interval)+1, update_interval);
-+ pstat_init(&ps.swap_out, (long)(0.5/update_interval)+1, update_interval);
-+ pstat_init(&ps.disk_read, (long)(0.5/update_interval)+1, update_interval);
-+ pstat_init(&ps.disk_write, (long)(0.5/update_interval)+1, update_interval);
- f = fopen("/proc/swaps","r");
- //if (!f) { perror("/proc/swaps"); exit(1); }
- if (f) {
-diff -pudr wmhdplop-0.9.9/procstat.h wmhdplop-0.9.9-fixed/procstat.h
---- wmhdplop-0.9.9/procstat.h 2004-03-14 12:07:15.000000000 +0100
-+++ wmhdplop-0.9.9-fixed/procstat.h 2010-06-25 21:45:52.146334994 +0200
-@@ -4,7 +4,7 @@
-
- struct pstat {
- unsigned long total;
-- int nslice, cur_slice;
-+ long nslice, cur_slice;
- unsigned long *slices;
- float update_interval;
- };
-@@ -15,7 +15,7 @@ typedef struct {
- struct pstat disk_read, disk_write;
- } ProcStats;
-
--void pstat_init(struct pstat *pst, int nslice, float update_interval);
-+void pstat_init(struct pstat *pst, long nslice, float update_interval);
- float pstat_current(struct pstat *pst);
- void pstat_add(struct pstat *pst, unsigned long v);
- void pstat_advance(struct pstat *pst);