summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmnetload/wmnetload-1.3-r5.ebuild')
-rw-r--r--x11-plugins/wmnetload/wmnetload-1.3-r5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-plugins/wmnetload/wmnetload-1.3-r5.ebuild b/x11-plugins/wmnetload/wmnetload-1.3-r5.ebuild
new file mode 100644
index 000000000000..c6acb1681762
--- /dev/null
+++ b/x11-plugins/wmnetload/wmnetload-1.3-r5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Network interface monitor dockapp"
+HOMEPAGE="https://github.com/bbidulock/wmnetload"
+SRC_URI="https://github.com/bbidulock/wmnetload/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND=">=x11-libs/libdockapp-0.7:="
+
+PATCHES=( "${FILESDIR}/${P}-r4-configure.patch" )
+
+src_prepare() {
+ default
+ sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i src/*.c || die
+ eautoreconf
+}