summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmpinboard/wmpinboard-1.0.1-r1.ebuild')
-rw-r--r--x11-plugins/wmpinboard/wmpinboard-1.0.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-plugins/wmpinboard/wmpinboard-1.0.1-r1.ebuild b/x11-plugins/wmpinboard/wmpinboard-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..428b51dc5d3f
--- /dev/null
+++ b/x11-plugins/wmpinboard/wmpinboard-1.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Window Maker dock applet resembling a miniature pinboard"
+HOMEPAGE="https://github.com/bbidulock/wmpinboard"
+SRC_URI="https://github.com/bbidulock/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=( "${FILESDIR}"/${P}-memcmp.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}