summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmstickynotes/wmstickynotes-0.7-r1.ebuild')
-rw-r--r--x11-plugins/wmstickynotes/wmstickynotes-0.7-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/wmstickynotes/wmstickynotes-0.7-r1.ebuild b/x11-plugins/wmstickynotes/wmstickynotes-0.7-r1.ebuild
new file mode 100644
index 000000000000..5350be8726ff
--- /dev/null
+++ b/x11-plugins/wmstickynotes/wmstickynotes-0.7-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A dockapp for keeping small notes around on the desktop"
+HOMEPAGE="https://sourceforge.net/projects/wmstickynotes/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_configure() {
+ append-cppflags -D_GNU_SOURCE #874927
+
+ default
+}