summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmtimer')
-rw-r--r--x11-plugins/wmtimer/metadata.xml24
-rw-r--r--x11-plugins/wmtimer/wmtimer-2.92-r3.ebuild (renamed from x11-plugins/wmtimer/wmtimer-2.92-r2.ebuild)17
2 files changed, 21 insertions, 20 deletions
diff --git a/x11-plugins/wmtimer/metadata.xml b/x11-plugins/wmtimer/metadata.xml
index b1f32fa558ec..a07ab7abb0ab 100644
--- a/x11-plugins/wmtimer/metadata.xml
+++ b/x11-plugins/wmtimer/metadata.xml
@@ -1,15 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person">
- <email>voyageur@gentoo.org</email>
- <name>Bernard Cafarelli</name>
-</maintainer>
-
-<longdescription>
-WMTimer is a dockable alarm clock for Windowmaker or Blackbox which can be run
-in alarm, countdown timer, or chronograph mode. In alarm or timer mode, you can
-either execute a command or sound the system bell when the time is reached.
-WMTimer is configurable through the command line or the GTK GUI.
-</longdescription>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription>
+ WMTimer is a dockable alarm clock for Windowmaker or Blackbox which can be run
+ in alarm, countdown timer, or chronograph mode. In alarm or timer mode, you can
+ either execute a command or sound the system bell when the time is reached.
+ WMTimer is configurable through the command line or the GTK GUI.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bbidulock/wmtimer</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/x11-plugins/wmtimer/wmtimer-2.92-r2.ebuild b/x11-plugins/wmtimer/wmtimer-2.92-r3.ebuild
index bcf6d63c094c..aeb6a3896127 100644
--- a/x11-plugins/wmtimer/wmtimer-2.92-r2.ebuild
+++ b/x11-plugins/wmtimer/wmtimer-2.92-r3.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit multilib toolchain-funcs
+EAPI=8
+
+inherit toolchain-funcs
DESCRIPTION="Dockable clock which can run in alarm, countdown timer or chronograph mode"
HOMEPAGE="https://github.com/bbidulock/wmtimer"
SRC_URI="https://github.com/bbidulock/wmtimer/releases/download/v${PV}/${P}.tar.gz"
+S="${WORKDIR}/${P}/${PN}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 ~sparc x86"
-IUSE=""
RDEPEND=">=dev-libs/glib-2
x11-libs/gtk+:2
x11-libs/libXpm
x11-libs/libXext
x11-libs/libX11"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/${P}/${PN}
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
sed -i -e "s|\$(CFLAGS)||" Makefile || die