summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmweather+')
-rw-r--r--x11-plugins/wmweather+/Manifest1
-rw-r--r--x11-plugins/wmweather+/files/wmweather+-2.17-gcc-10.patch23
-rw-r--r--x11-plugins/wmweather+/files/wmweather+-2.18-configure-clang16.patch67
-rw-r--r--x11-plugins/wmweather+/wmweather+-2.17.ebuild23
-rw-r--r--x11-plugins/wmweather+/wmweather+-2.18-r1.ebuild (renamed from x11-plugins/wmweather+/wmweather+-2.18.ebuild)11
5 files changed, 74 insertions, 51 deletions
diff --git a/x11-plugins/wmweather+/Manifest b/x11-plugins/wmweather+/Manifest
index 11e7543e7bc7..1204dbc1d818 100644
--- a/x11-plugins/wmweather+/Manifest
+++ b/x11-plugins/wmweather+/Manifest
@@ -1,2 +1 @@
-DIST wmweather+-2.17.tar.gz 212763 BLAKE2B e810ecaf6858bba0cb3bdb32517f5c1cbaa552ed071b1ce6dfca33b41ad75c5272616c9be78930f47ee3980d2ab8c51a29caaec627c5e608e9c2790d940cfe65 SHA512 45622513792698f1adf4a686506913146e2a24c9ff39fda1129132aae864528184aa122b525e00b079f416fd131c1369ff95e430c4c63877bdc166c982f841eb
DIST wmweather+-2.18.tar.gz 206062 BLAKE2B 14fe0b49b5541d5e093c958d1c12c4c28c3bae53f8539402a61800d1817bf22eae426d4733e08ae3f1e90057e7dd297a9412d62e5edd9fb973b0a9e799b3f792 SHA512 538325b1d2bd7dd3a89a006d88868e02a71318b6e49001033d0f543965fb21f91b265e116d3b929a096e99719c99241d520a7eb395ec55f721de0d01dcbedbc0
diff --git a/x11-plugins/wmweather+/files/wmweather+-2.17-gcc-10.patch b/x11-plugins/wmweather+/files/wmweather+-2.17-gcc-10.patch
deleted file mode 100644
index 1b26aa3936e5..000000000000
--- a/x11-plugins/wmweather+/files/wmweather+-2.17-gcc-10.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -Naur wmweather+-2.17.orig/wmgeneral/wmgeneral-x11.c wmweather+-2.17/wmgeneral/wmgeneral-x11.c
---- wmweather+-2.17.orig/wmgeneral/wmgeneral-x11.c 2014-02-07 20:17:44.000000000 +0100
-+++ wmweather+-2.17/wmgeneral/wmgeneral-x11.c 2020-02-24 22:11:47.226905019 +0100
-@@ -94,6 +94,7 @@
- GC NormalGC;
- GC RedrawGC;
- XpmIcon wmgen;
-+Display *display;
-
- /***********************/
- /* Function Prototypes */
-diff -Naur wmweather+-2.17.orig/wmgeneral/wmgeneral-x11.h wmweather+-2.17/wmgeneral/wmgeneral-x11.h
---- wmweather+-2.17.orig/wmgeneral/wmgeneral-x11.h 2014-02-07 20:17:44.000000000 +0100
-+++ wmweather+-2.17/wmgeneral/wmgeneral-x11.h 2020-02-24 22:10:45.233884234 +0100
-@@ -17,7 +17,7 @@
- /* Global variable */
- /*******************/
-
--Display *display;
-+extern Display *display;
-
- /***********************/
- /* Function Prototypes */
diff --git a/x11-plugins/wmweather+/files/wmweather+-2.18-configure-clang16.patch b/x11-plugins/wmweather+/files/wmweather+-2.18-configure-clang16.patch
new file mode 100644
index 000000000000..68a4d3f33190
--- /dev/null
+++ b/x11-plugins/wmweather+/files/wmweather+-2.18-configure-clang16.patch
@@ -0,0 +1,67 @@
+https://sourceforge.net/p/wmweatherplus/bugs/21/
+https://bugs.gentoo.org/870958
+
+Port the configure script to C99 by avoiding calls to the undeclared
+exit function. Future compilers are likely to reject implicit
+function declarations by default; this C features was removed from the
+language in 1999.
+
+--- a/m4/snprintf.m4
++++ b/m4/snprintf.m4
+@@ -24,7 +24,7 @@ int snprintf(char *str, size_t size, const char *format, ...);
+ #endif
+ ]],
+ [[char foo[]="ABC"; snprintf(foo, 2, "%d", 12);
+-exit((foo[0]=='1' && foo[1]=='\0' && foo[2]=='C')?0:1);]])],
++return (foo[0]=='1' && foo[1]=='\0' && foo[2]=='C')?0:1;]])],
+ [x_cv_func_snprintf_size=yes],
+ [x_cv_func_snprintf_size=no],
+ [x_cv_func_snprintf_size=no])])
+@@ -52,7 +52,7 @@ AC_CACHE_CHECK([if snprintf return value is sane], x_cv_func_snprintf_retval,
+ int snprintf(char *str, size_t size, const char *format, ...);
+ #endif
+ ]],
+-[[char foo[10]; exit((snprintf(foo, 1, "%d", 9876)==4)?0:1);]])],
++[[char foo[10]; return (snprintf(foo, 1, "%d", 9876)==4)?0:1;]])],
+ [x_cv_func_snprintf_retval=yes],
+ [x_cv_func_snprintf_retval=no],
+ [x_cv_func_snprintf_retval=no])])
+@@ -79,7 +79,7 @@ AC_CACHE_CHECK([if snprintf(NULL, 0, ...) works], x_cv_func_snprintf_null_ok,
+ int snprintf(char *str, size_t size, const char *format, ...);
+ #endif
+ ]],
+-[int r=snprintf(NULL, 0, "%d", 100); exit((r==3 || r==-1)?0:1);])],
++[int r=snprintf(NULL, 0, "%d", 100); return (r==3 || r==-1)?0:1;])],
+ [x_cv_func_snprintf_null_ok=yes],
+ [x_cv_func_snprintf_null_ok=no],
+ [x_cv_func_snprintf_null_ok=no])])
+--- a/m4/vsnprintf.m4
++++ b/m4/vsnprintf.m4
+@@ -37,7 +37,7 @@ int doit(char *str, size_t size, const char *format, ...){
+ }
+ ]],
+ [[char foo[]="ABC"; doit(foo, 2, "%d", 12);
+-exit((foo[0]=='1' && foo[1]=='\0' && foo[2]=='C')?0:1);]])],
++return (foo[0]=='1' && foo[1]=='\0' && foo[2]=='C')?0:1;]])],
+ [x_cv_func_vsnprintf_size=yes],
+ [x_cv_func_vsnprintf_size=no],
+ [x_cv_func_vsnprintf_size=no])])
+@@ -74,7 +74,7 @@ int doit(char *str, size_t size, const char *format, ...){
+ return r;
+ }
+ ]],
+-[[char foo[10]; exit((doit(foo, 1, "%d", 9876)==4)?0:1);]])],
++[[char foo[10]; return (doit(foo, 1, "%d", 9876)==4)?0:1;]])],
+ [x_cv_func_vsnprintf_retval=yes],
+ [x_cv_func_vsnprintf_retval=no],
+ [x_cv_func_vsnprintf_retval=no])])
+@@ -110,7 +110,7 @@ int doit(char *str, size_t size, const char *format, ...){
+ return r;
+ }
+ ]],
+-[int r=doit(NULL, 0, "%d", 100); exit((r==3 || r==-1)?0:1);])],
++[int r=doit(NULL, 0, "%d", 100); return (r==3 || r==-1)?0:1;])],
+ [x_cv_func_vsnprintf_null_ok=yes],
+ [x_cv_func_vsnprintf_null_ok=no],
+ [x_cv_func_vsnprintf_null_ok=no])])
+
diff --git a/x11-plugins/wmweather+/wmweather+-2.17.ebuild b/x11-plugins/wmweather+/wmweather+-2.17.ebuild
deleted file mode 100644
index 94bc2487217f..000000000000
--- a/x11-plugins/wmweather+/wmweather+-2.17.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A dockapp for displaying data collected from METAR, AVN, ETA, and MRF forecasts"
-HOMEPAGE="https://www.sourceforge.net/projects/wmweatherplus/"
-SRC_URI="mirror://sourceforge/wmweatherplus/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~mips ppc ~ppc64 ~sparc x86"
-IUSE=""
-
-DEPEND="dev-libs/libpcre
- >=net-misc/curl-7.17.1
- x11-libs/libXpm
- x11-libs/libXext
- x11-libs/libX11
- x11-wm/windowmaker"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
diff --git a/x11-plugins/wmweather+/wmweather+-2.18.ebuild b/x11-plugins/wmweather+/wmweather+-2.18-r1.ebuild
index 7dffde689df7..2494176425ef 100644
--- a/x11-plugins/wmweather+/wmweather+-2.18.ebuild
+++ b/x11-plugins/wmweather+/wmweather+-2.18-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,11 +6,11 @@ inherit autotools
DESCRIPTION="A dockapp for displaying data collected from METAR, AVN, ETA, and MRF forecasts"
HOMEPAGE="https://www.sourceforge.net/projects/wmweatherplus/"
-SRC_URI="mirror://sourceforge/wmweatherplus/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/wmweatherplus/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ~mips ppc ~ppc64 ~sparc x86"
IUSE=""
DEPEND="dev-libs/libpcre
@@ -21,7 +21,10 @@ DEPEND="dev-libs/libpcre
x11-wm/windowmaker"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-ar.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-ar.patch
+ "${FILESDIR}"/${P}-configure-clang16.patch
+)
src_prepare() {
default