summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/kitty/kitty-0.32.2.ebuild')
-rw-r--r--x11-terms/kitty/kitty-0.32.2.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/x11-terms/kitty/kitty-0.32.2.ebuild b/x11-terms/kitty/kitty-0.32.2.ebuild
index ad738d565f30..5099295c3d2c 100644
--- a/x11-terms/kitty/kitty-0.32.2.ebuild
+++ b/x11-terms/kitty/kitty-0.32.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit edo go-env optfeature multiprocessing
+inherit edo flag-o-matic go-env optfeature multiprocessing
inherit python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]]; then
@@ -132,6 +132,16 @@ src_compile() {
local -x GOFLAGS="-p=$(makeopts_jobs) -v -x"
use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
+ # workaround link errors with Go + gcc + -g3 (bug #924436),
+ # retry now and then to see if can be dropped
+ tc-is-gcc &&
+ CGO_CFLAGS=$(
+ CFLAGS=${CGO_CFLAGS}
+ replace-flags -g3 -g
+ replace-flags -ggdb3 -ggdb
+ printf %s "${CFLAGS}"
+ )
+
local conf=(
--disable-link-time-optimization
--ignore-compiler-warnings