summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/qterminal/qterminal-0.17.0.ebuild')
-rw-r--r--x11-terms/qterminal/qterminal-0.17.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-terms/qterminal/qterminal-0.17.0.ebuild b/x11-terms/qterminal/qterminal-0.17.0.ebuild
new file mode 100644
index 000000000000..c19beb9ee0e0
--- /dev/null
+++ b/x11-terms/qterminal/qterminal-0.17.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt-based multitab terminal emulator"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.9.0"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ ~x11-libs/qtermwidget-${PV}
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/qterminal-0.16.1-appdata.patch" )
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}