summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xfce4-terminal/Manifest1
-rw-r--r--x11-terms/xfce4-terminal/xfce4-terminal-1.1.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-terms/xfce4-terminal/Manifest b/x11-terms/xfce4-terminal/Manifest
index dbc0c39a767c..fd5d14196274 100644
--- a/x11-terms/xfce4-terminal/Manifest
+++ b/x11-terms/xfce4-terminal/Manifest
@@ -1 +1,2 @@
DIST xfce4-terminal-1.0.4.tar.bz2 1009367 BLAKE2B 48a618f8ea98ad0408d8e54d4489358874e9e0e3c6a7011f298d0fed21512783258598cc59013c7406128e68d7311ddf64fdb13f9517306a819db50edc0555cc SHA512 76ea8f296fe1c128dc70d8aabf23447300ba83405d52e844abec89049968bac51fe47fd7545a76e4a421275c6a2f230f326ed3a25083bf536f17fc3218b05fce
+DIST xfce4-terminal-1.1.0.tar.bz2 1021840 BLAKE2B 981d73362dd7e1122b893c0761ca8f758e9382bc49a5ad985d11a953aa17e65b0c372b8a6350ed2671665508e625fbfbf4532dadc88211c14b6848c195d247dc SHA512 c01f0e7a293c4e55b4ee151eb8beb5ff9634a8134b545452c87ee9fa9928507e73bda1a63634900f669a58353877c2cb3f48e7b95cf236bdc857ca311c73c86f
diff --git a/x11-terms/xfce4-terminal/xfce4-terminal-1.1.0.ebuild b/x11-terms/xfce4-terminal/xfce4-terminal-1.1.0.ebuild
new file mode 100644
index 000000000000..17e638f1825b
--- /dev/null
+++ b/x11-terms/xfce4-terminal/xfce4-terminal-1.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A terminal emulator for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/terminal/start
+ https://gitlab.xfce.org/apps/xfce4-terminal/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="utempter"
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/libpcre2-10.00:=
+ >=x11-libs/gtk+-3.22.0:3
+ x11-libs/libX11
+ >=x11-libs/vte-0.51.3:2.91
+ >=xfce-base/libxfce4ui-4.17.5:=[gtk3(+)]
+ >=xfce-base/xfconf-4.16.0:=
+ utempter? ( sys-libs/libutempter:= )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_with utempter)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}