summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild')
-rw-r--r--x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild
index 94af0ef56281..479d6cc8396c 100644
--- a/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild
+++ b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild
@@ -20,6 +20,12 @@ BDEPEND="media-gfx/optipng
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:3"
+src_prepare() {
+ sed -i -e 's:-Werror -O0 -pipe:${CFLAGS} ${CPPFLAGS} ${LDFLAGS}:' \
+ svgtopng/Makefile || die
+ default
+}
+
src_configure() {
# custom script
./configure --prefix="${EPREFIX}/usr" || die