summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/greybird/greybird-3.22.14.ebuild')
-rw-r--r--x11-themes/greybird/greybird-3.22.14.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-themes/greybird/greybird-3.22.14.ebuild b/x11-themes/greybird/greybird-3.22.14.ebuild
new file mode 100644
index 000000000000..04169b5ab38c
--- /dev/null
+++ b/x11-themes/greybird/greybird-3.22.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson optfeature
+
+DESCRIPTION="Greybird Desktop Suite"
+HOMEPAGE="https://github.com/shimmerproject/Greybird"
+SRC_URI="https://github.com/shimmerproject/${PN^}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+
+# Theme files, no test case available.
+RESTRICT="test"
+
+RDEPEND="x11-libs/gtk+:3
+ x11-themes/gtk-engines-murrine"
+DEPEND="${RDEPEND}
+ dev-lang/sassc
+ dev-libs/glib:2"
+
+S="${WORKDIR}/${P^}"
+
+pkg_postinst() {
+ elog "Optional uninstalled features:"
+ optfeature "matching icon theme" x11-themes/elementary-xfce-icon-theme
+ optfeature "matching cursor theme" x11-themes/vanilla-dmz-xcursors
+}