summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/nuvox/nuvox-07.1-r1.ebuild')
-rw-r--r--x11-themes/nuvox/nuvox-07.1-r1.ebuild21
1 files changed, 8 insertions, 13 deletions
diff --git a/x11-themes/nuvox/nuvox-07.1-r1.ebuild b/x11-themes/nuvox/nuvox-07.1-r1.ebuild
index 328020ee4d52..7770506ddd90 100644
--- a/x11-themes/nuvox/nuvox-07.1-r1.ebuild
+++ b/x11-themes/nuvox/nuvox-07.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
MY_P=nuvoX_${PV}
@@ -12,18 +12,13 @@ SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="virtual/imagemagick-tools[png]"
-
RESTRICT="strip binchecks"
-S=${WORKDIR}/${MY_P}
+BDEPEND="virtual/imagemagick-tools[png]"
-src_prepare() {
- sed -i -e '/rm -fr/d' -e '/tar cf/d' buildset || die
-}
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${PN}-07.1-fix-buildset.patch )
src_compile() {
./buildset || die
@@ -31,8 +26,8 @@ src_compile() {
src_install() {
dodoc nuvoX_0.7/readme.txt
- rm nuvoX_0.7/{readme,license}.txt
+ rm nuvoX_0.7/{readme,license}.txt || die
insinto /usr/share/icons/${PN}
- doins -r nuvoX_0.7/*
+ doins -r nuvoX_0.7/.
}