summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild')
-rw-r--r--x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild b/x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild
new file mode 100644
index 000000000000..610e5b31139b
--- /dev/null
+++ b/x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Icon themes for smplayer"
+HOMEPAGE="http://www.smplayer.eu/"
+SRC_URI="mirror://sourceforge/smplayer/${P}.tar.bz2"
+
+LICENSE="CC-BY-2.5 CC-BY-SA-2.5 CC-BY-SA-3.0 CC0-1.0 GPL-2 GPL-3+ LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4"
+RDEPEND="media-video/smplayer"
+
+src_prepare() {
+ default
+
+ # bug 544108
+ sed -i -e "s| rcc| \"$(qt4_get_bindir)\"/rcc|" themes/Makefile || die
+
+ # bug 544160
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+}
+
+src_install() {
+ rm themes/Makefile themes/H2O/Makefile || die
+ insinto /usr/share/smplayer
+ doins -r themes
+ dodoc Changelog README.txt
+}