summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild')
-rw-r--r--x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild36
1 files changed, 19 insertions, 17 deletions
diff --git a/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild b/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
index 457528857ffc..365c0df59781 100644
--- a/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
+++ b/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
@@ -1,37 +1,43 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit gnome2-utils
+EAPI=7
+
+inherit xdg
DESCRIPTION="a derivative of the standard Tango theme, using a more orange approach"
HOMEPAGE="http://packages.ubuntu.com/gutsy/x11/tangerine-icon-theme"
-SRC_URI="mirror://ubuntu/pool/universe/t/${PN}/${PN}_${PV}.tar.gz
+SRC_URI="
+ mirror://ubuntu/pool/universe/t/${PN}/${PN}_${PV}.tar.gz
https://www.gentoo.org/images/gentoo-logo.svg"
LICENSE="CC-BY-SA-2.5 LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="minimal"
-
RESTRICT="binchecks strip"
-RDEPEND="!minimal? ( || ( x11-themes/adwaita-icon-theme kde-frameworks/oxygen-icons ) )"
-DEPEND="dev-util/intltool
- >=gnome-base/librsvg-2.34
+RDEPEND="
+ !minimal? (
+ || (
+ x11-themes/adwaita-icon-theme
+ kde-frameworks/oxygen-icons
+ )
+ )"
+BDEPEND="
+ dev-util/intltool
+ gnome-base/librsvg
sys-devel/gettext
- >=x11-misc/icon-naming-utils-0.8.90"
+ x11-misc/icon-naming-utils"
-DOCS="AUTHORS README"
+PATCHES=( "${FILESDIR}"/${PN}-0.27-libexec.patch )
src_unpack() {
unpack ${PN}_${PV}.tar.gz
}
src_prepare() {
- sed -i \
- -e 's:lib/icon-naming-utils/icon:libexec/icon:' \
- Makefile || die
+ xdg_src_prepare
cp "${DISTDIR}"/gentoo-logo.svg scalable/places/start-here.svg || die
@@ -45,7 +51,3 @@ src_prepare() {
src_compile() {
emake index.theme
}
-
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }