summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-murrine/files/0.98.2-implicit-functions.patch29
-rw-r--r--x11-themes/gtk-engines-murrine/gtk-engines-murrine-0.98.2-r3.ebuild (renamed from x11-themes/gtk-engines-murrine/gtk-engines-murrine-0.98.2-r2.ebuild)4
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-murrine/files/0.98.2-implicit-functions.patch b/x11-themes/gtk-engines-murrine/files/0.98.2-implicit-functions.patch
new file mode 100644
index 000000000000..cb0db5b67c1d
--- /dev/null
+++ b/x11-themes/gtk-engines-murrine/files/0.98.2-implicit-functions.patch
@@ -0,0 +1,29 @@
+--- a/src/murrine_rc_style.h
++++ b/src/murrine_rc_style.h
+@@ -154,5 +154,6 @@
+ };
+
+ GType murrine_rc_style_get_type (void);
++void murrine_rc_style_register_types (GTypeModule *);
+
+ #endif /* MURRINE_RC_STYLE_H */
+--- a/src/murrine_style.h
++++ b/src/murrine_style.h
+@@ -102,5 +102,6 @@
+ };
+
+ GType murrine_style_get_type (void);
++void murrine_style_register_types (GTypeModule *);
+
+ #endif /* MURRINE_STYLE_H */
+--- a/src/support.h 2012-01-17 18:46:01.000000000 +0100
++++ b/src/support.h 2021-11-28 01:08:50.868702336 +0100
+@@ -148,5 +148,8 @@
+ G_GNUC_INTERNAL void murrine_get_notebook_tab_position (GtkWidget *widget,
+ gboolean *start,
+ gboolean *end);
++G_GNUC_INTERNAL gboolean murrine_object_is_a (const GObject *object,
++ const gchar *type_name);
++G_GNUC_INTERNAL gboolean murrine_widget_is_ltr (GtkWidget *widget);
+
+ #endif /* SUPPORT_H */
diff --git a/x11-themes/gtk-engines-murrine/gtk-engines-murrine-0.98.2-r2.ebuild b/x11-themes/gtk-engines-murrine/gtk-engines-murrine-0.98.2-r3.ebuild
index dd124f302e19..1c5274f04bf3 100644
--- a/x11-themes/gtk-engines-murrine/gtk-engines-murrine-0.98.2-r2.ebuild
+++ b/x11-themes/gtk-engines-murrine/gtk-engines-murrine-0.98.2-r3.ebuild
@@ -27,6 +27,10 @@ BDEPEND=">=dev-util/intltool-0.37.1
sys-devel/gettext
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/0.98.2-implicit-functions.patch
+)
+
DOCS=( AUTHORS ChangeLog NEWS TODO )
src_prepare() {