summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/aewm++/aewm++-1.1.5-r2.ebuild')
-rw-r--r--x11-wm/aewm++/aewm++-1.1.5-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild b/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild
new file mode 100644
index 000000000000..f80697fffa4a
--- /dev/null
+++ b/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A window manager with more modern features than aewm but with the same look and feel"
+HOMEPAGE="https://github.com/frankhale/aewmpp"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README
+}