summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/aewm++/aewm++-1.1.5-r3.ebuild')
-rw-r--r--x11-wm/aewm++/aewm++-1.1.5-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-wm/aewm++/aewm++-1.1.5-r3.ebuild b/x11-wm/aewm++/aewm++-1.1.5-r3.ebuild
new file mode 100644
index 000000000000..1afc79dbe2dc
--- /dev/null
+++ b/x11-wm/aewm++/aewm++-1.1.5-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A window manager with more modern features than aewm"
+HOMEPAGE="https://github.com/frankhale/aewmpp"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-makefile.patch
+)
+
+src_configure() {
+ tc-export CXX
+}