summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/fvwm3/fvwm3-9999.ebuild')
-rw-r--r--x11-wm/fvwm3/fvwm3-9999.ebuild51
1 files changed, 43 insertions, 8 deletions
diff --git a/x11-wm/fvwm3/fvwm3-9999.ebuild b/x11-wm/fvwm3/fvwm3-9999.ebuild
index 8bc78a359bc5..343a8c61635c 100644
--- a/x11-wm/fvwm3/fvwm3-9999.ebuild
+++ b/x11-wm/fvwm3/fvwm3-9999.ebuild
@@ -3,6 +3,11 @@
EAPI=8
+# Doc generation requires pulls in asciidoc/ruby, we'll prebuild docs
+# for release ebuilds.
+# Scripting for this is in sam-gentoo-scripts.
+: ${FVWM3_DOCS_PREBUILT:=1}
+
PYTHON_COMPAT=( python3_{10..12} )
GO_OPTIONAL=1
inherit autotools desktop flag-o-matic go-module python-single-r1 toolchain-funcs
@@ -16,13 +21,16 @@ if [[ ${PV} == 9999 ]]; then
EGIT_BRANCH="main"
else
SRC_URI="https://github.com/fvwmorg/fvwm3/releases/download/${PV}/${P}.tar.gz"
+ if [[ ${FVWM3_DOCS_PREBUILT} == 1 ]]; then
+ SRC_URI+=" https://deps.gentoo.zip/x11-wm/fvwm3/${P}-docs.tar.xz"
+ fi
KEYWORDS="~amd64 ~riscv"
fi
LICENSE="GPL-2+ FVWM
go? ( Apache-2.0 BSD MIT )"
SLOT="0"
-IUSE="bidi debug doc +go netpbm nls perl readline stroke svg tk lock"
+IUSE="bidi debug +go netpbm nls perl readline stroke svg tk lock"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}"
@@ -41,12 +49,17 @@ fi
BDEPEND="
virtual/pkgconfig
- doc? ( dev-libs/libxslt
- dev-ruby/asciidoctor )
app-arch/unzip
go? ( >=dev-lang/go-1.14 )
"
+if [[ ${FVWM3_DOCS_PREBUILT} == 0 ]]; then
+ BDEPEND+="
+ dev-libs/libxslt
+ dev-ruby/asciidoctor
+ "
+fi
+
RDEPEND="${PYTHON_DEPS}
${COMMON_DEPEND}
!x11-wm/fvwm
@@ -116,7 +129,6 @@ src_configure() {
--with-imagepath=/usr/include/X11/bitmaps:/usr/include/X11/pixmaps:/usr/share/icons/fvwm
--enable-package-subdirs
$(use_enable bidi)
- $(use_enable doc mandoc)
$(use_enable go golang)
$(use_enable nls)
$(use_enable nls iconv)
@@ -126,6 +138,19 @@ src_configure() {
--enable-png
)
+ if [[ ${FVWM3_DOCS_PREBUILT} == 1 ]]; then
+ myconf+=(
+ --enable-mandoc
+ --enable-htmldoc
+ )
+ else
+ # Probably not required, but let's be safe
+ myconf+=(
+ --disable-mandoc
+ --disable-htmldoc
+ )
+ fi
+
use readline && myconf+=( --without-termcap-library )
econf "${myconf[@]}"
@@ -133,12 +158,22 @@ src_configure() {
src_compile() {
PREFIX="${EPREFIX}/usr" emake AR="$(tc-getAR)"
- if [[ ${PV} == *9999 ]]; then
- use doc && emake -C doc
- fi
}
src_install() {
+ # Since we're manually handling docs installation, let's do that first
+ # and then install the rest of the files via emake
+ local HTML_DOCS
+ if [[ ${FVWM3_DOCS_PREBUILT} == 1 ]] ; then
+ doman "${WORKDIR}"/${P}-docs/man/**/*.[0-8]
+ HTML_DOCS="${WORKDIR}"/${P}-docs/html/*
+ else
+ HTML_DOCS="${S}"/doc/*.html
+ doman "${S}"/doc/*.[0-8]
+ fi
+
+ einstalldocs
+
emake DESTDIR="${ED}" prefix="/usr" exec_prefix="/usr" datarootdir="/usr/share" install
exeinto /etc/X11/Sessions
@@ -149,9 +184,9 @@ src_install() {
python_scriptinto "/usr/bin"
python_doscript "${ED}/usr/bin/FvwmCommand" "${ED}/usr/bin/fvwm-menu-desktop"
- einstalldocs
make_session_desktop fvwm3 /usr/bin/fvwm3
+
}
pkg_postinst() {