summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/openbox/openbox-3.6.1-r3.ebuild')
-rw-r--r--x11-wm/openbox/openbox-3.6.1-r3.ebuild28
1 files changed, 19 insertions, 9 deletions
diff --git a/x11-wm/openbox/openbox-3.6.1-r3.ebuild b/x11-wm/openbox/openbox-3.6.1-r3.ebuild
index ac1119033279..736a89bce398 100644
--- a/x11-wm/openbox/openbox-3.6.1-r3.ebuild
+++ b/x11-wm/openbox/openbox-3.6.1-r3.ebuild
@@ -4,21 +4,21 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit multilib autotools python-single-r1 eutils
+inherit autotools python-single-r1
DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager"
-HOMEPAGE="http://openbox.org/"
+HOMEPAGE="http://openbox.org/wiki/Main_Page"
+
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="git://git.openbox.org/dana/openbox"
- SRC_URI="branding? (
- https://dev.gentoo.org/~hwoarang/distfiles/surreal-gentoo.tar.gz )"
else
- SRC_URI="http://openbox.org/dist/openbox/${P}.tar.gz
- branding? ( https://dev.gentoo.org/~hwoarang/distfiles/surreal-gentoo.tar.gz )"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+ SRC_URI="http://openbox.org/dist/openbox/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
fi
+SRC_URI+=" branding? ( https://dev.gentoo.org/~hwoarang/distfiles/surreal-gentoo.tar.gz )"
+
LICENSE="GPL-2"
SLOT="3"
IUSE="branding debug imlib nls session startup-notification static-libs svg xdg"
@@ -45,11 +45,12 @@ RDEPEND="dev-libs/glib:2
dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
')
)
- "
+"
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
- x11-base/xorg-proto"
+ x11-base/xorg-proto
+"
PATCHES=(
"${FILESDIR}/${PN}-3.5.2-gnome-session.patch"
@@ -57,7 +58,16 @@ PATCHES=(
"${FILESDIR}/${PN}-3.6.1-py3-xdg.patch"
)
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ git-r3_src_unpack
+ fi
+
+ default
+}
+
src_prepare() {
+ use xdg && python-single-r1_pkg_setup
default
sed -i \
-e "s:-O0 -ggdb ::" \