summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/ratpoison/ratpoison-9999.ebuild')
-rw-r--r--x11-wm/ratpoison/ratpoison-9999.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/x11-wm/ratpoison/ratpoison-9999.ebuild b/x11-wm/ratpoison/ratpoison-9999.ebuild
index 0353bcb130d4..568ee3d06f21 100644
--- a/x11-wm/ratpoison/ratpoison-9999.ebuild
+++ b/x11-wm/ratpoison/ratpoison-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit autotools elisp-common eutils git-r3 toolchain-funcs
DESCRIPTION="window manager without mouse dependency"
@@ -11,27 +11,35 @@ EGIT_REPO_URI="git://git.savannah.nongnu.org/ratpoison.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="debug emacs +history sloppy +xft"
+IUSE="debug emacs +history sloppy +xft +xrandr"
RDEPEND="
emacs? ( virtual/emacs )
history? ( sys-libs/readline:= )
xft? ( x11-libs/libXft )
+ xrandr? ( x11-libs/libXrandr )
virtual/perl-Pod-Parser
- x11-libs/libXinerama
x11-libs/libXtst
"
DEPEND="
${RDEPEND}
- app-arch/xz-utils
virtual/pkgconfig
+ x11-proto/randrproto
+ x11-proto/xproto
"
SITEFILE=50ratpoison-gentoo.el
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
+DOCS=(
+ AUTHORS
+ ChangeLog
+ NEWS
+ README
+ TODO
+)
src_prepare() {
- epatch "${FILESDIR}"/ratpoison.el-gentoo.patch
+ eapply "${FILESDIR}"/ratpoison.el-gentoo.patch
+
eautoreconf
}
@@ -40,13 +48,14 @@ src_configure() {
$(use_enable debug) \
$(use_enable history) \
$(use_with xft) \
+ $(use_with xrandr) \
--without-electric-fence
}
src_compile() {
emake CFLAGS="${CFLAGS}"
if use emacs; then
- elisp-compile contrib/ratpoison.el || die "elisp-compile failed"
+ elisp-compile contrib/ratpoison.el || die
fi
if use sloppy; then