summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/stumpwm-contrib/stumpwm-contrib-20171028.ebuild')
-rw-r--r--x11-wm/stumpwm-contrib/stumpwm-contrib-20171028.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-wm/stumpwm-contrib/stumpwm-contrib-20171028.ebuild b/x11-wm/stumpwm-contrib/stumpwm-contrib-20171028.ebuild
new file mode 100644
index 000000000000..06ec6f840939
--- /dev/null
+++ b/x11-wm/stumpwm-contrib/stumpwm-contrib-20171028.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="Extension Modules for StumpWM"
+HOMEPAGE="https://github.com/stumpwm/stumpwm-contrib/"
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="${HOMEPAGE}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-3 BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=x11-wm/stumpwm-1.0.0"
+
+CONTRIBCATEGORIES="media modeline minor-mode util"
+
+src_install() {
+ common-lisp-install-sources -t all ${CONTRIBCATEGORIES}
+ dobin util/stumpish/stumpish
+ dobin util/pinentry/stumpwm-pinentry
+ dodoc README.org
+}