summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/stumpwm-contrib/stumpwm-contrib-99999999.ebuild')
-rw-r--r--x11-wm/stumpwm-contrib/stumpwm-contrib-99999999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-wm/stumpwm-contrib/stumpwm-contrib-99999999.ebuild b/x11-wm/stumpwm-contrib/stumpwm-contrib-99999999.ebuild
new file mode 100644
index 000000000000..4d27f2cc3696
--- /dev/null
+++ b/x11-wm/stumpwm-contrib/stumpwm-contrib-99999999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit common-lisp-3
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/stumpwm/${PN}"
+else
+ SRC_URI="mirror://gentoo/${PN}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Extension Modules for StumpWM"
+HOMEPAGE="https://github.com/stumpwm/stumpwm-contrib/"
+
+LICENSE="GPL-2 GPL-3 BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=x11-wm/stumpwm-0.9.9"
+
+CONTRIBCATEGORIES="media modeline minor-mode util"
+
+src_install() {
+ common-lisp-install-sources -t all ${CONTRIBCATEGORIES}
+ dodoc README.org
+}