summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/xoat/xoat-9999.ebuild')
-rw-r--r--x11-wm/xoat/xoat-9999.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/x11-wm/xoat/xoat-9999.ebuild b/x11-wm/xoat/xoat-9999.ebuild
deleted file mode 100644
index 31b9838afc84..000000000000
--- a/x11-wm/xoat/xoat-9999.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit git-r3 savedconfig toolchain-funcs
-
-DESCRIPTION="X Obstinate Asymmetric Tiler"
-HOMEPAGE="https://github.com/seanpringle/xoat"
-EGIT_REPO_URI="https://github.com/seanpringle/xoat"
-
-LICENSE="MIT"
-SLOT="0"
-
-DEPEND="
- x11-libs/libX11
- x11-libs/libXft
- x11-libs/libXinerama
-"
-RDEPEND="
- ${DEPEND}
- !savedconfig? ( x11-misc/dmenu )
-"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
- restore_config config.h
-}
-
-src_configure() {
- tc-export CC PKG_CONFIG
-}
-
-src_compile() {
- XOAT_COMPILE=(
- ${CC} -o ${PN} ${PN}.c ${CFLAGS} -std=c99 ${LDFLAGS}
- $(${PKG_CONFIG} --cflags --libs x11 xinerama xft)
- )
- echo ${XOAT_COMPILE[@]}
- ${XOAT_COMPILE[@]} || die
-}
-
-src_install() {
- dobin xoat
- dodoc status xinitrc xoat.md xoatrc
- doman xoat.1
- save_config config.h
-}