summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/xpra/files')
-rw-r--r--x11-wm/xpra/files/xpra-0.10.1-prefix.patch30
-rw-r--r--x11-wm/xpra/files/xpra-0.10.12-launcher.patch10
-rw-r--r--x11-wm/xpra/files/xpra-0.12.0-prefix.patch27
-rw-r--r--x11-wm/xpra/files/xpra-0.13.1-ignore-gentoo-no-compile.patch11
-rw-r--r--x11-wm/xpra/files/xpra-0.14.0-prefix.patch27
-rw-r--r--x11-wm/xpra/files/xpra-0.15.0-prefix.patch27
-rw-r--r--x11-wm/xpra/files/xpra-0.7.1-ignore-gentoo-no-compile.patch11
7 files changed, 143 insertions, 0 deletions
diff --git a/x11-wm/xpra/files/xpra-0.10.1-prefix.patch b/x11-wm/xpra/files/xpra-0.10.1-prefix.patch
new file mode 100644
index 000000000000..1e8e759abaca
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-0.10.1-prefix.patch
@@ -0,0 +1,30 @@
+Index: xpra-0.10.1/setup.py
+===================================================================
+--- xpra-0.10.1.orig/setup.py
++++ xpra-0.10.1/setup.py
+@@ -896,8 +896,8 @@ else:
+ return {}
+ if "install" in sys.argv:
+ #prepare default [/usr/local]/etc configuration files:
+- if sys.prefix == '/usr':
+- etc_prefix = '/etc/xpra'
++ if sys.prefix[-4:] == '/usr':
++ etc_prefix = sys.prefix[:-4] + '/etc/xpra'
+ else:
+ etc_prefix = sys.prefix + '/etc/xpra'
+
+Index: xpra-0.10.1/xpra/scripts/config.py
+===================================================================
+--- xpra-0.10.1.orig/xpra/scripts/config.py
++++ xpra-0.10.1/xpra/scripts/config.py
+@@ -344,8 +344,8 @@ def read_xpra_defaults():
+ #first, read the global defaults:
+ if sys.platform.startswith("win"):
+ conf_dir = os.path.dirname(os.path.abspath(sys.executable))
+- elif sys.prefix == '/usr':
+- conf_dir = '/etc/xpra'
++ elif sys.prefix[-4:] == '/usr':
++ conf_dir = sys.prefix[:-4] + '/etc/xpra'
+ else:
+ conf_dir = sys.prefix + '/etc/xpra/'
+ defaults = read_xpra_conf(conf_dir)
diff --git a/x11-wm/xpra/files/xpra-0.10.12-launcher.patch b/x11-wm/xpra/files/xpra-0.10.12-launcher.patch
new file mode 100644
index 000000000000..edd42a8e837b
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-0.10.12-launcher.patch
@@ -0,0 +1,10 @@
+--- src/xpra/client/gtk_base/client_launcher.py
++++ src/xpra/client/gtk_base/client_launcher.py
+@@ -18,5 +18,6 @@
+ import pygtk
+ pygtk.require('2.0')
+-import gtk.gdk
++import gtk
++from gtk import gdk
+ import gobject
+ gobject.threads_init()
diff --git a/x11-wm/xpra/files/xpra-0.12.0-prefix.patch b/x11-wm/xpra/files/xpra-0.12.0-prefix.patch
new file mode 100644
index 000000000000..cce5e9dbfac7
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-0.12.0-prefix.patch
@@ -0,0 +1,27 @@
+--- xpra-0.12.0/xpra/scripts/config.py
++++ xpra-0.12.0/xpra/scripts/config.py
+@@ -188,9 +188,9 @@
+ #OSX and win32 use binary installers,
+ #we must look for the default config in the bundled resource location:
+ conf_dir = get_resources_dir()
+- elif sys.prefix == '/usr':
++ elif sys.prefix[-4:] == '/usr':
+ #default posix config location:
+- conf_dir = '/etc/xpra'
++ conf_dir = sys.prefix[:-4] + '/etc/xpra'
+ else:
+ #hope the prefix is something like "/usr/local":
+ conf_dir = sys.prefix + '/etc/xpra/'
+--- xpra-0.12.0/setup.py
++++ xpra-0.12.0/setup.py
+@@ -990,8 +990,8 @@
+ return {}
+ if "install" in sys.argv:
+ #prepare default [/usr/local]/etc configuration files:
+- if sys.prefix == '/usr':
+- etc_prefix = '/etc/xpra'
++ if sys.prefix[-4:] == '/usr':
++ etc_prefix = sys.prefix[:-4] + '/etc/xpra'
+ else:
+ etc_prefix = sys.prefix + '/etc/xpra'
+
diff --git a/x11-wm/xpra/files/xpra-0.13.1-ignore-gentoo-no-compile.patch b/x11-wm/xpra/files/xpra-0.13.1-ignore-gentoo-no-compile.patch
new file mode 100644
index 000000000000..9c580a513557
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-0.13.1-ignore-gentoo-no-compile.patch
@@ -0,0 +1,11 @@
+--- xpra-0.13.1/setup.py
++++ xpra-0.13.1/setup.py
+@@ -395,7 +395,7 @@
+ #then expects to find the cython modules!? ie:
+ #python2.7 setup.py build -b build-2.7 install --no-compile --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
+ if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
+- return
++ pass
+ cython_version_check(min_version)
+ from Cython.Distutils import build_ext
+ ext_modules.append(extension)
diff --git a/x11-wm/xpra/files/xpra-0.14.0-prefix.patch b/x11-wm/xpra/files/xpra-0.14.0-prefix.patch
new file mode 100644
index 000000000000..140abbbbbc0b
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-0.14.0-prefix.patch
@@ -0,0 +1,27 @@
+--- xpra-0.14.0/xpra/platform/paths.py
++++ xpra-0.14.0/xpra/platform/paths.py
+@@ -22,9 +22,9 @@
+
+ def get_system_conf_dir():
+ #the system wide configuration directory
+- if sys.prefix == '/usr':
++ if sys.prefix[-4:] == '/usr':
+ #default posix config location:
+- default_conf_dir = '/etc/xpra'
++ default_conf_dir = sys.prefix[:-4] + '/etc/xpra'
+ else:
+ #hope the prefix is something like "/usr/local":
+ default_conf_dir = sys.prefix + '/etc/xpra/'
+--- xpra-0.14.0/setup.py
++++ xpra-0.14.0/setup.py
+@@ -1470,8 +1470,8 @@
+ #prepare default [/usr/local]/etc configuration files:
+ if '--user' in sys.argv:
+ etc_prefix = 'etc/xpra'
+- elif sys.prefix == '/usr':
+- etc_prefix = '/etc/xpra'
++ elif sys.prefix[-4:] == '/usr':
++ etc_prefix = sys.prefix[:-4] + '/etc/xpra'
+ else:
+ etc_prefix = sys.prefix + '/etc/xpra'
+
diff --git a/x11-wm/xpra/files/xpra-0.15.0-prefix.patch b/x11-wm/xpra/files/xpra-0.15.0-prefix.patch
new file mode 100644
index 000000000000..32e8be80dd46
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-0.15.0-prefix.patch
@@ -0,0 +1,27 @@
+--- xpra-0.15.0/setup.py
++++ xpra-0.15.0/setup.py
+@@ -1612,8 +1612,8 @@
+ #prepare default [/usr/local]/etc configuration files:
+ if '--user' in sys.argv:
+ etc_prefix = 'etc/xpra'
+- elif sys.prefix == '/usr':
+- etc_prefix = '/etc/xpra'
++ elif sys.prefix[-4:] == '/usr':
++ etc_prefix = sys.prefix[:-4] + '/etc/xpra'
+ else:
+ etc_prefix = sys.prefix + '/etc/xpra'
+
+--- xpra-0.15.0/xpra/platform/paths.py
++++ xpra-0.15.0/xpra/platform/paths.py
+@@ -30,9 +30,9 @@
+ return env_conf_dir
+ prefix = get_install_prefix()
+ #the system wide configuration directory
+- if prefix == '/usr':
++ if sys.prefix[-4:] == '/usr':
+ #default posix config location:
+- return '/etc/xpra'
++ return sys.prefix[:-4] + '/etc/xpra'
+ #hope the prefix is something like "/usr/local" or "$HOME/.local":
+ return prefix + '/etc/xpra/'
+
diff --git a/x11-wm/xpra/files/xpra-0.7.1-ignore-gentoo-no-compile.patch b/x11-wm/xpra/files/xpra-0.7.1-ignore-gentoo-no-compile.patch
new file mode 100644
index 000000000000..31d619daddc9
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-0.7.1-ignore-gentoo-no-compile.patch
@@ -0,0 +1,11 @@
+--- xpra-0.7.1/setup.py
++++ xpra-0.7.1/setup.py
+@@ -135,7 +135,7 @@
+ #then expects to find the cython modules!? ie:
+ #python2.7 setup.py build -b build-2.7 install --no-compile --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
+ if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
+- return
++ pass
+ global ext_modules, cmdclass
+ cython_version_check(min_version)
+ from Cython.Distutils import build_ext