summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/selectwm/files/selectwm-0.4.1-autotools.patch26
-rw-r--r--x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch15
-rw-r--r--x11-wm/selectwm/selectwm-0.4.1-r2.ebuild (renamed from x11-wm/selectwm/selectwm-0.4.1-r1.ebuild)25
3 files changed, 41 insertions, 25 deletions
diff --git a/x11-wm/selectwm/files/selectwm-0.4.1-autotools.patch b/x11-wm/selectwm/files/selectwm-0.4.1-autotools.patch
new file mode 100644
index 000000000000..11dbcd3b94f0
--- /dev/null
+++ b/x11-wm/selectwm/files/selectwm-0.4.1-autotools.patch
@@ -0,0 +1,26 @@
+* Respect CFLAGS, don't strip binaries
+* Don't check for configure.in (EAPI 8)
+
+http://bugs.gentoo.org/252124
+
+--- a/configure.in
++++ b/configure.in
+@@ -1,6 +1,6 @@
+ dnl Process this file with autoconf to produce a configure script.
+
+-AC_INIT(configure.in)
++AC_INIT
+ AM_INIT_AUTOMAKE(selectwm, 0.4.1)
+ AM_CONFIG_HEADER(config.h)
+ AM_MAINTAINER_MODE
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -10,5 +10,6 @@
+ modify.c modify.h \
+ misc.h define.h
+
+-LIBS = @GTK_LIBS@
+-AM_CFLAGS = -s -O2 -Wall @GTK_CFLAGS@ -DLOCALEDIR=\"$(datadir)/locale\"
++selectwm_LDADD = @GTK_LIBS@
++selectwm_CFLAGS = @GTK_CFLAGS@
++selectwm_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\"
diff --git a/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch b/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch
deleted file mode 100644
index 4287ca2d2cbb..000000000000
--- a/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Respect CFLAGS, don't strip binaries
-
-http://bugs.gentoo.org/show_bug.cgi?id=252124
-
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -10,5 +10,6 @@
- modify.c modify.h \
- misc.h define.h
-
--LIBS = @GTK_LIBS@
--AM_CFLAGS = -s -O2 -Wall @GTK_CFLAGS@ -DLOCALEDIR=\"$(datadir)/locale\"
-+selectwm_LDADD = @GTK_LIBS@
-+selectwm_CFLAGS = @GTK_CFLAGS@
-+selectwm_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\"
diff --git a/x11-wm/selectwm/selectwm-0.4.1-r1.ebuild b/x11-wm/selectwm/selectwm-0.4.1-r2.ebuild
index e06d7d38dc00..43301bdf930c 100644
--- a/x11-wm/selectwm/selectwm-0.4.1-r1.ebuild
+++ b/x11-wm/selectwm/selectwm-0.4.1-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit autotools
DESCRIPTION="window manager selector tool"
@@ -13,17 +14,16 @@ SLOT="2"
KEYWORDS="amd64 ppc sparc x86"
IUSE="nls"
-DOCS=( AUTHORS README sample.xinitrc )
-
-RDEPEND="x11-libs/gtk+:2
+RDEPEND="
+ x11-libs/gtk+:2
dev-libs/glib:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}/${P}-enable-deprecated-gtk.patch"
- "${FILESDIR}/${P}-glibc-2.10.patch"
- "${FILESDIR}/${P}-nostrip.patch"
+ "${FILESDIR}"/${P}-enable-deprecated-gtk.patch
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+ "${FILESDIR}"/${P}-autotools.patch
)
src_prepare() {
@@ -36,3 +36,8 @@ src_configure() {
--program-suffix=2 \
$(use_enable nls)
}
+
+src_install() {
+ default
+ dodoc sample.xinitrc
+}