summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/goomwwm/files/goomwwm-1.0.0-makefile.patch29
-rw-r--r--x11-wm/goomwwm/goomwwm-1.0.0-r2.ebuild (renamed from x11-wm/goomwwm/goomwwm-1.0.0-r1.ebuild)28
2 files changed, 39 insertions, 18 deletions
diff --git a/x11-wm/goomwwm/files/goomwwm-1.0.0-makefile.patch b/x11-wm/goomwwm/files/goomwwm-1.0.0-makefile.patch
new file mode 100644
index 000000000000..b5d7ddb873f5
--- /dev/null
+++ b/x11-wm/goomwwm/files/goomwwm-1.0.0-makefile.patch
@@ -0,0 +1,29 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,11 +1,9 @@
+-CFLAGS?=-Wall -O2
+-LDADD?=$(shell pkg-config --cflags --libs x11 xinerama x11 xft)
++CFLAGS += -Wall
++CPPFLAGS += $(shell $(PKG_CONFIG) --cflags x11 xinerama x11 xft)
++LDLIBS += $(shell $(PKG_CONFIG) --libs x11 xinerama x11 xft)
+
+-normal:
+- $(CC) -o goomwwm goomwwm.c $(CFLAGS) $(LDADD) $(LDFLAGS)
+-
+-debug:
+- $(CC) -o goomwwm-debug goomwwm.c $(CFLAGS) -g -DDEBUG $(LDADD)
++all: goomwwm
++goomwwm.c: proto
+
+ proto:
+ cat *.c | egrep '^(void|int|char|unsigned|client|Window|winlist|XWindow)' | sed -r 's/\)/);/' > proto.h
+@@ -13,7 +11,5 @@
+ docs:
+ pandoc -s -w man goomwwm.md -o goomwwm.1
+
+-all: proto normal debug docs
+-
+ clean:
+- rm -f goomwwm goomwwm-debug
+\ No newline at end of file
++ rm -f goomwwm goomwwm-debug
diff --git a/x11-wm/goomwwm/goomwwm-1.0.0-r1.ebuild b/x11-wm/goomwwm/goomwwm-1.0.0-r2.ebuild
index f51897cf633f..506169ced6bf 100644
--- a/x11-wm/goomwwm/goomwwm-1.0.0-r1.ebuild
+++ b/x11-wm/goomwwm/goomwwm-1.0.0-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit flag-o-matic toolchain-funcs
@@ -17,28 +17,20 @@ IUSE="debug"
RDEPEND="
x11-libs/libXft
x11-libs/libX11
- x11-libs/libXinerama
-"
+ x11-libs/libXinerama"
DEPEND="
${RDEPEND}
- virtual/pkgconfig
- x11-base/xorg-proto
-"
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
-src_prepare() {
- default
- sed -i -e 's|$(LDADD) $(LDFLAGS)|$(LDFLAGS) $(LDADD)|g' Makefile || die
-}
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
src_configure() {
- use debug && append-cflags -DDEBUG
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" proto normal
+ tc-export CC PKG_CONFIG
+ use debug && append-cppflags -DDEBUG
}
src_install() {
- dobin ${PN}
- doman ${PN}.1
+ dobin goomwwm
+ doman goomwwm.1
}