summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/exo/exo-0.12.7.ebuild')
-rw-r--r--xfce-base/exo/exo-0.12.7.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/xfce-base/exo/exo-0.12.7.ebuild b/xfce-base/exo/exo-0.12.7.ebuild
deleted file mode 100644
index 5ba1dd00d3eb..000000000000
--- a/xfce-base/exo/exo-0.12.7.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit xdg-utils
-
-DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
-HOMEPAGE="https://www.xfce.org/projects/"
-SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
-IUSE="gtk2"
-
-RDEPEND=">=dev-lang/perl-5.6
- >=dev-libs/glib-2.42:=
- dev-perl/URI
- >=x11-libs/gtk+-3.22:3=
- >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
- >=xfce-base/libxfce4util-4.12:=
- gtk2? ( >=x11-libs/gtk+-2.24:2= )"
-DEPEND="${RDEPEND}
- dev-util/gtk-doc-am
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig"
-
-src_configure() {
- local myconf=(
- $(use_enable gtk2)
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}