summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfce4-settings')
-rw-r--r--xfce-base/xfce4-settings/Manifest1
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.18.4.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/Manifest b/xfce-base/xfce4-settings/Manifest
index 34fea8f3ea92..02eee0e7728e 100644
--- a/xfce-base/xfce4-settings/Manifest
+++ b/xfce-base/xfce4-settings/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-settings-4.18.3.tar.bz2 1553936 BLAKE2B 6b8ab7a520044496223ae09ca0c09c7395968a79f937773ce847921869e58aa081e943feb17e72dd7565ca572c445d41baf4a7beb20067fa90400c9181e01890 SHA512 81a79a886966a5f017f066ece6ad134d132b1fa18c4f8b203212fb56b45a62fe8d9814f3039cc9bda41c52338b7e80685e9671cd80db3f2f9bcd99dd7bc47d8e
+DIST xfce4-settings-4.18.4.tar.bz2 1557097 BLAKE2B 0269ed1778becc547ba187c096d7c9938cc00f56fb1c9312c9d0eb9b5344d4785f88abadecf391724699de2cb28b35ffed057f06e85f3e098a902a4047969a9c SHA512 2f9e2de4a3a0cc59b4701b44899464532fbae8805270485d2821b65b9d78be54bb636c4cd4205de97e18c13b20912fcd1f4ca0b3baa561bf1a783829f53a06a0
DIST xfce4-settings-4.19.0.tar.bz2 2370986 BLAKE2B 64a25238afffb99fefe488d2218652ce714af7f783620ed5dc9d848911293bec25f95d81089cc9bb971f73e55a861c4953ebb9affd501eeb10f27a49dfc1b01b SHA512 8892d19f723bfacea1c7df8afa5abc7d45984f8b1070b24316cb8ca04ef621489632314ce1e361eda94e036df7a36b4a7988a7853469bbad1bde9e6bef9113d6
DIST xfce4-settings-4.19.1.tar.bz2 2406390 BLAKE2B 3b528d7ea0a44e8a59b0e9612d116a17592db1b57932873b86f218c30721781c25cf5a0bbc3deefde6ef3370947f20033fac282b8a8fd9883ccb33a91f438750 SHA512 9d08c3dda27fcb3832b74cf32bedb4a051d46437f31b07a838f58bd324fca63ad6159558deca0b29de5d22b467c08a690d5eafef5e0581a3bc8782ba1771a937
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.18.4.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.18.4.ebuild
new file mode 100644
index 000000000000..e16f84483f81
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.18.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfce4-settings/start
+ https://gitlab.xfce.org/xfce/xfce4-settings/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="colord input_devices_libinput libcanberra libnotify upower +xklavier"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.66.0
+ media-libs/fontconfig
+ >=x11-libs/gtk+-3.24.0:3
+ x11-libs/libX11
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/garcon-0.2:=
+ >=xfce-base/exo-4.15.1:=
+ >=xfce-base/libxfce4ui-4.17.0:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfconf-4.13:=
+ colord? ( x11-misc/colord:= )
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ input_devices_libinput? ( x11-drivers/xf86-input-libinput )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ upower? ( >=sys-power/upower-0.9.23 )
+ xklavier? ( >=x11-libs/libxklavier-5 )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable upower upower-glib)
+ $(use_enable input_devices_libinput xorg-libinput)
+ $(use_enable libnotify)
+ $(use_enable colord)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}