summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfdesktop')
-rw-r--r--xfce-base/xfdesktop/Manifest1
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index f876eb63dc82..bda42f223abe 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -1,2 +1,3 @@
DIST xfdesktop-4.18.1.tar.bz2 2133258 BLAKE2B 3d4f54b64a6adc5f52bf6b48862b1fbf9b9608113035fdce89a2cb08a674f773f42edc0e1d05a27e89de7df71f7d53f400b794a2a79888cf51570c3ab060db8b SHA512 cafb1e274bbabf1704a6452532fc79657af26eaf92a58374f87a70f31c35fbf213319c6658b3d18bfca2d555b69e07e46949407d1f80e5a37f48e76bbde9dc3e
+DIST xfdesktop-4.19.0.tar.bz2 2145725 BLAKE2B 18ed97b8bb9ee769de29490383fd089eb884081c95e662350c9e0c05aa9812a4f44e8911c5bb74e026aa1fea22840245a68e1514dd6e439af8dd553c82da562c SHA512 dd8d479b7a43733dc49f692bd88ad5a290d5fa4cdbddf42be293921c750d3017e9c6671cc56ba8888a0df8d3951b0993dffa88418032ad7c68f85d8756081e40
DIST xfdesktop-4.19.1.tar.bz2 2523196 BLAKE2B fb499192d1c5fbbc78d3e5d9c38aa5a7bc5f19058946be21aafbd5ffe2dc31bb197a4822d92094d914ab01a416409612c39a2478bacfd12e6f2bf98a5ad262c3 SHA512 f07cdcedf8eb47bf14688a88251075ac84a876294f95cf49845f206374f15355d0b641099f402a3a0295c6b737a3d865315c00bb1fec6b0558027faa31f6e19f
diff --git a/xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild b/xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild
new file mode 100644
index 000000000000..9a65e0082db2
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfdesktop/start
+ https://gitlab.xfce.org/xfce/xfdesktop/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="libnotify +thunar wayland X"
+REQUIRED_USE="|| ( wayland X )"
+
+DEPEND="
+ >=x11-libs/cairo-1.16
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3[wayland?,X?]
+ x11-libs/libX11
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/libxfce4windowing-4.19.1:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? ( >=xfce-base/thunar-4.17.10:= )
+ wayland? ( >=gui-libs/gtk-layer-shell-0.7.0 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable wayland)
+ $(use_enable wayland gtk-layer-shell)
+ $(use_enable X x11)
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}