summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-netspeed-plugin/xfce4-netspeed-plugin-0.3.ebuild')
-rw-r--r--xfce-extra/xfce4-netspeed-plugin/xfce4-netspeed-plugin-0.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-netspeed-plugin/xfce4-netspeed-plugin-0.3.ebuild b/xfce-extra/xfce4-netspeed-plugin/xfce4-netspeed-plugin-0.3.ebuild
new file mode 100644
index 000000000000..630da0e9d75a
--- /dev/null
+++ b/xfce-extra/xfce4-netspeed-plugin/xfce4-netspeed-plugin-0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A network transfer rate monitoring panel plug-in, inspired by Gnome's Netspeed applet"
+HOMEPAGE="http://code.google.com/p/xfce4-netspeed-plugin/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ >=gnome-base/libgtop-2
+ x11-libs/gtk+:2
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ DOCS=( AUTHORS README )
+}