summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.6.0.ebuild')
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.6.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.6.0.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.6.0.ebuild
new file mode 100644
index 000000000000..a535ab4e79d4
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake xdg-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin/"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/libintl
+ x11-libs/gtk+:3
+ xfce-base/exo:=
+ xfce-base/garcon:=
+ xfce-base/libxfce4ui:=
+ xfce-base/libxfce4util:=
+ xfce-base/xfce4-panel:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# upstream does fancy stuff in other build types
+CMAKE_BUILD_TYPE=Debug
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ -DENABLE_LINK_TIME_OPTIMIZATION=OFF
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}