summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.5.0.ebuild')
-rw-r--r--xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.5.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.5.0.ebuild b/xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.5.0.ebuild
new file mode 100644
index 000000000000..b6fd0528f2ac
--- /dev/null
+++ b/xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Panel plugin to put the maximized window title and window buttons on the panel"
+HOMEPAGE="https://gitlab.xfce.org/panel-plugins/xfce4-windowck-plugin/"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ x11-libs/gtk+:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.14:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}