summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-29 19:23:22 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-29 19:23:22 +0000
commit3719bdf369a04e685e629ddb99ee71080e46937f (patch)
tree69dabadecc65ee03eb79feb2690ef84822ed14b6 /app-admin/chrpath/chrpath-0.13-r2.ebuild
parentremove mask for app-accessibility/speechd since it has been removed for bug #... (diff)
downloadhistorical-3719bdf369a04e685e629ddb99ee71080e46937f.tar.gz
historical-3719bdf369a04e685e629ddb99ee71080e46937f.tar.bz2
historical-3719bdf369a04e685e629ddb99ee71080e46937f.zip
revbump with improved patch for prefix. Thanks to Fabian Groffen and Mario Fetka for their help. Bug #365817
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'app-admin/chrpath/chrpath-0.13-r2.ebuild')
-rw-r--r--app-admin/chrpath/chrpath-0.13-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/chrpath/chrpath-0.13-r2.ebuild b/app-admin/chrpath/chrpath-0.13-r2.ebuild
new file mode 100644
index 000000000000..dff81c7cf066
--- /dev/null
+++ b/app-admin/chrpath/chrpath-0.13-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chrpath/chrpath-0.13-r2.ebuild,v 1.1 2011/08/29 19:23:22 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="chrpath can modify the rpath and runpath of ELF executables"
+HOMEPAGE="http://directory.fsf.org/project/chrpath/"
+# original upstream no longer exists (ftp://ftp.hungry.com/pub/hungry)
+SRC_URI="http://ftp.tux.org/pub/X-Windows/ftp.hungry.com/chrpath/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-multilib.patch
+ epatch "${FILESDIR}"/${PN}-keepgoing.patch
+ epatch "${FILESDIR}"/${P}-testsuite-1.patch
+ sed -i -e '/^docdir/d' Makefile.am # use standard docdir
+ eautoreconf
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog AUTHORS NEWS README
+}