summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-23 02:36:02 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-23 02:36:02 +0000
commit8ef588f01f39d3e5cb62f2ad5b9a9ceb15484e8f (patch)
treed613c7e025eca019d9cdae7301383dfa99082bf7 /app-admin/watchfolder/watchfolder-0.3.3.ebuild
parentRespect CC. (diff)
downloadhistorical-8ef588f01f39d3e5cb62f2ad5b9a9ceb15484e8f.tar.gz
historical-8ef588f01f39d3e5cb62f2ad5b9a9ceb15484e8f.tar.bz2
historical-8ef588f01f39d3e5cb62f2ad5b9a9ceb15484e8f.zip
Respect CFLAGS, LDFLAGS and CC.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64
Diffstat (limited to 'app-admin/watchfolder/watchfolder-0.3.3.ebuild')
-rw-r--r--app-admin/watchfolder/watchfolder-0.3.3.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/app-admin/watchfolder/watchfolder-0.3.3.ebuild b/app-admin/watchfolder/watchfolder-0.3.3.ebuild
index 6e0e3ec7bba5..b49d4cda5c11 100644
--- a/app-admin/watchfolder/watchfolder-0.3.3.ebuild
+++ b/app-admin/watchfolder/watchfolder-0.3.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchfolder/watchfolder-0.3.3.ebuild,v 1.4 2006/03/19 21:39:53 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchfolder/watchfolder-0.3.3.ebuild,v 1.5 2008/10/23 02:36:02 flameeyes Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Watches directories and processes files, similar to the watchfolder option of Acrobat Distiller."
HOMEPAGE="http://freshmeat.net/projects/watchd/"
@@ -23,9 +23,18 @@ src_unpack() {
# patch to remove warnings on 64 bit systems
epatch ${FILESDIR}/${PV}-64bit.patch || die
- sed -i "3s/OPT=/OPT=${CFLAGS} /" Makefile
+ sed -i \
+ -e '/-c -o/s:OPT:CFLAGS:' \
+ -e 's:(\(LD\)\?OPT):(LDFLAGS) $(CFLAGS):' \
+ -e 's:gcc:$(CC):' \
+ Makefile || die "sed Makefile failed"
}
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+
src_install() {
dobin watchd
insinto /etc