summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-07 09:35:32 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-07 09:35:32 +0000
commit187605bf87157c174968d648934abc3aa601fe92 (patch)
treea01bd9c8153762eec63c208bf531bd9724a2ddfd /sys-apps/dmtcp/dmtcp-1.2.6.ebuild
parentppc stable #429036 (diff)
downloadhistorical-187605bf87157c174968d648934abc3aa601fe92.tar.gz
historical-187605bf87157c174968d648934abc3aa601fe92.tar.bz2
historical-187605bf87157c174968d648934abc3aa601fe92.zip
Version bump as current version doesn't compile for a long time (#367687).
Package-Manager: portage-2.1.11.24/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/dmtcp/dmtcp-1.2.6.ebuild')
-rw-r--r--sys-apps/dmtcp/dmtcp-1.2.6.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/dmtcp/dmtcp-1.2.6.ebuild b/sys-apps/dmtcp/dmtcp-1.2.6.ebuild
new file mode 100644
index 000000000000..e946c4d2c069
--- /dev/null
+++ b/sys-apps/dmtcp/dmtcp-1.2.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmtcp/dmtcp-1.2.6.ebuild,v 1.1 2012/10/07 09:35:32 pacho Exp $
+
+EAPI=4
+inherit elisp-common eutils multilib
+
+DESCRIPTION="DMTCP is the Distributed MultiThreaded Checkpointing tool."
+HOMEPAGE="http://dmtcp.sourceforge.net/index.html"
+SRC_URI="mirror://sourceforge/dmtcp/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug emacs fast mpi trace"
+
+RDEPEND="sys-libs/readline
+ app-arch/gzip
+ sys-kernel/linux-headers
+ emacs? ( dev-lisp/clisp )
+ mpi? ( virtual/mpi )
+ || ( app-shells/dash
+ app-shells/zsh
+ app-shells/tcsh
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/patch"
+
+src_configure() {
+ local myconf="--disable-stale-socket-handling"
+
+ if use debug; then
+ use trace && myconf=" ${myconf} --enable-ptrace-support"
+ myconf=" ${myconf} --disable-pid-virtualization"
+ fi
+
+ use fast && myconf=" ${myconf} --disable-pid-virtualization \
+ --enable-forked-checkpointing \
+ --enable-allocator"
+
+ use mpi && myconf=" ${myconf} --with-mpich=/usr/bin"
+
+ econf $(use_enable debug) $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc TODO QUICK-START ${PN}/README
+
+ dodir /usr/share/${PF}/examples
+ mv "${D}"usr/$(get_libdir)/${PN}/examples "${D}"usr/share/${PF}/examples
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}