summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2014-07-06 21:24:30 +0000
committerWilliam Hubbs <williamh@gentoo.org>2014-07-06 21:24:30 +0000
commita948d211a903547f1a93d87933d24b0cd03c85a3 (patch)
tree7ebacfd7b62fca1fc4ee0b1db0d3a43c811fcb5a /sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
parentStable on amd64 and x86, wrt bug #516344 (diff)
downloadhistorical-a948d211a903547f1a93d87933d24b0cd03c85a3.tar.gz
historical-a948d211a903547f1a93d87933d24b0cd03c85a3.tar.bz2
historical-a948d211a903547f1a93d87933d24b0cd03c85a3.zip
reinstate the separate inherit call for git-r3.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x30C46538
Diffstat (limited to 'sys-apps/gentoo-functions/gentoo-functions-9999.ebuild')
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
index 0e426d0eee31..f75276851bb4 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild,v 1.3 2014/05/10 17:20:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild,v 1.4 2014/07/06 21:24:10 williamh Exp $
EAPI=5
if [[ ${PV} = 9999* ]]; then
- vcs=git-r3
+ inherit git-r3
EGIT_REPO_URI="git://github.com/gentoo/${PN}.git"
else
SRC_URI="http://dev.gentoo.org/~williamh/dist/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
fi
-inherit ${vcs} toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="base functions required by all gentoo systems"
HOMEPAGE="http://www.gentoo.org"