summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2015-08-03 16:18:29 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2015-08-03 16:18:29 +0000
commite3e333e5ad435523f410cc6ad6d46adfdb91878b (patch)
tree6576dc1668730269a65770a3f429edbe0703b179 /sys-cluster/csync2/csync2-2.0.ebuild
parentRemove older versions due to vulnerabilities. (diff)
downloadhistorical-e3e333e5ad435523f410cc6ad6d46adfdb91878b.tar.gz
historical-e3e333e5ad435523f410cc6ad6d46adfdb91878b.tar.bz2
historical-e3e333e5ad435523f410cc6ad6d46adfdb91878b.zip
add postgres support
Package-Manager: portage-2.2.20/cvs/Linux x86_64 Manifest-Sign-Key: 0xB658FA13
Diffstat (limited to 'sys-cluster/csync2/csync2-2.0.ebuild')
-rw-r--r--sys-cluster/csync2/csync2-2.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-cluster/csync2/csync2-2.0.ebuild b/sys-cluster/csync2/csync2-2.0.ebuild
index bd500e34e2ed..1eade62f0945 100644
--- a/sys-cluster/csync2/csync2-2.0.ebuild
+++ b/sys-cluster/csync2/csync2-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-2.0.ebuild,v 1.3 2015/08/03 14:03:34 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-2.0.ebuild,v 1.4 2015/08/03 16:18:22 ultrabug Exp $
EAPI=5
@@ -13,17 +13,18 @@ SRC_URI="http://oss.linbit.com/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
-IUSE="mysql sqlite ssl xinetd"
+IUSE="mysql postgres sqlite ssl xinetd"
RDEPEND=">=net-libs/librsync-0.9.5
mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql:= )
sqlite? ( >=dev-db/sqlite-3.0 )
ssl? ( >=net-libs/gnutls-2.7.3 )
xinetd? ( sys-apps/xinetd )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-REQUIRED_USE="|| ( mysql sqlite )"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
SLOT="0"
src_configure() {
@@ -32,6 +33,7 @@ src_configure() {
--localstatedir=/var \
--sysconfdir=/etc/csync2 \
$(use_enable mysql) \
+ $(use_enable postgres) \
$(use_enable sqlite sqlite3) \
$(use_enable ssl gnutls)
}