summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-11-19 21:33:33 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-11-19 21:33:33 +0000
commit38fd79fe866b21aed353de6fc9fecd4fc7b1ab5e (patch)
treef7e8fed9baaf5d7a22697b6b6923e26d48a8708c /sys-cluster/libquo/libquo-1.2.ebuild
parentinitial commit (diff)
downloadhistorical-38fd79fe866b21aed353de6fc9fecd4fc7b1ab5e.tar.gz
historical-38fd79fe866b21aed353de6fc9fecd4fc7b1ab5e.tar.bz2
historical-38fd79fe866b21aed353de6fc9fecd4fc7b1ab5e.zip
initial commit
Package-Manager: portage-2.2.8-r2/cvs/Linux x86_64 Manifest-Sign-Key: 0xC2000586
Diffstat (limited to 'sys-cluster/libquo/libquo-1.2.ebuild')
-rw-r--r--sys-cluster/libquo/libquo-1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-cluster/libquo/libquo-1.2.ebuild b/sys-cluster/libquo/libquo-1.2.ebuild
new file mode 100644
index 000000000000..bdec83962ba7
--- /dev/null
+++ b/sys-cluster/libquo/libquo-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libquo/libquo-1.2.ebuild,v 1.1 2014/11/19 21:33:27 ottxor Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="run-time tuning of process binding policies made easy"
+HOMEPAGE="http://losalamos.github.io/libquo/"
+SRC_URI="http://losalamos.github.io/${PN}/dists/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ virtual/mpi
+ sys-process/numactl
+ sys-apps/hwloc[numa,xml]
+ "
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ autotools-utils_src_configure CC=mpicc
+}